Fillet curve bug in GH1

Since there is no Serengeti - Grasshopper1 topic I’ll post it here:

Here’s a weird problem I’m getting in grasshopper for Rhino 5 as well as Rhino 6 beta.

When I try to fillet these curves with a radius of 3.00 mm it doesn’t work for a few curves and gives me the following error: 1. Solution exception:Object reference not set to an instance of an object.

When I try with a radius of 2.99 (or below) or 3.01 (or above) it works without a problem.

NOW. When I change it back to 3.00 and move the same curves which are linked in Rhino -20mm in Y-direction: It magically works.

What causes this and can it be fixed without having to switch diameter or move the original curves?

171112 Fillet (5.3 KB)
171112 Fillet error gh.3dm (45.3 KB)

See here, more examples which don’t work. The green shapes were able to be filleted, the other ones are not.

After some more testing I think I found out what is causing this error. You see that some shapes in the corner already have a radius before I do the fillet. That radius is the same as the radius I’m trying to use for filleting all shapes. So changing that first radius seemed to have solved it. But apparently that error also makes sure the fillet doesn’t work on some shapes that had no fillet before.

Is it possible to have the component check for existing radius and have the component throw an error saying that the radius cannot be present in the shape yet?

Also strange that it manages to fillet some of the curves but not the others. Or the fact that the filleting worked when I moved the curves…