Fillet certain corners and hatches with different radii?


#1

Hi,
V5.
After hatching I can see which corners need rounding up a bit, .

Fillet corners does all corners of a many segmented straight line shape (planar).
How can one do different corners with different radii and some not at all ?

I dont want to have to explode then join back together if I can avoid doing so

I also need the hatch fills to take on the same fillet. I see though the hatch ignores the command and filletCorners doesnt offer choice of curve or hatch in the pick, does one need to re-hatch ?

Steve


(Pascal Golay) #2

Hi Steve, I think you want the Fillet command, most likely.

-Pascal


#3

Hi Pascal,
the closed curve, drawn with mostly straight lines and many angular corners is drawn and hatch applied.

Running fillet command it says pick first curve I select my shape and it ‘blinks’.
nothing happens,

help menu video shows it dealing with two lines who have yet to have a radiused join.

Fillet seems wrong for a closed curve.

Steve


#4

I don’t get it. It prompts for a curve and you select a shape. Why don’t pick on a curve segment and then on the next to create the fillet ? You might not have to explode the closed curve before, _Fillet will work on the curve segments you pick. If you enable _Join=Yes option of the command, you do not have to join the created fillets and your curve remains a closed curve.

There is unfortunately no alternative as _Fillet is the command to fillet curves. If you want to fillet the curve you’ve created the hatch from, and see the hatch update without recreating it, then create the hatch with history. Then you can fillet your hatched curve and the hatch updates.

c.


#5

Hi
tried again and the hatch was hiding the result, or just a glitch. deleting the hatch sees a filleted corner. :slight_smile:
I then start again, with no hatch, hit record history at foot of screen, select both shapes, create hatch.
I see that record history then returned to neutral colour.
run fillet command select first then second lines, and get a fillet , both hatches at that moment disappear.

At least I can fillet it, even if hatch vanishes.
attached two of the items.
shapeTrace.3dm (26.8 KB)

how did you create that gif ? The assembly of command icons was also useful, again hows that done ?

I have Jing, hope this is viewable, no localised recording, most of screen.

Steve


#6

Please follow my reply above exactly. In your video you have _Join=No enabled in the _Fillet command. Your _Hatch is not hidden, it is not created since it needs a closed curve.

10 year old camtasia 3 :blush:

I’ve just created a new empty toolbar and copied the buttons into it which where used. You might read more about toolbars here.

c.


#7

Hi,
hope I have followed it, record history, create hatch, lock hatch, went gray for some reason, did fillet with join=yes.

hatch vanished.

here is the video.


Steve


#8

The locking of the hatch does not have anything to do with your problem it should work without that too. Read what the command line is showing after your fillets where done. I do not understand why your commandline prints:

History updated 4 objects

You have 2 objects right ?

c.


#9

@Steve1, i would just try things out using a simple example in such cases. If you make it work with eg. a rectangle, then the problem source are your curves.

@pascal, please take a closer look at those 2 curves posted above. There is indeed something fishy going on with them. The file has 8 unused hatch patterns, if you purge them, then hatch the curves with history and just move the curves, the hatches disappear. (V5 and V6).

c.


Hatch and History fail in side views
(Pascal Golay) #10

I see it… I’ll see what I can figure out, thanks.

https://mcneel.myjetbrains.com/youtrack/issue/RH-38738

-Pascal


#11

Hi,
both shapes details:-

video of rectangle as you suggest, still hatch vanishes:-

here is new file draw rectangle same issue:-

all done in V5
Steve


#12

@Steve1, interesting, i think you found a bug. If the curves are not in XYPlane space, _Hatch will not update. If you take your original curves posted above, then remap them from front view to top view, the history hatch just works.

c.


#13

Hi, pest control services needed.

Tried it in v4, see video.

that was without join=yes, and this is with join=yes

Steve


#14

@Steve1, have you read my reply above yours ? Your video shows front view…try top.

c.


#15

Yes, just seeing what V4 had in the way of the bug.
here is rectangle drawn in front then rotated to become top, I get an oddment occur,

file attached.
shapeTrace.3dm (27.9 KB)

Steve


#16

What do you get if you create your rectangle in the XYPlane, from the top view ?

c.


#17

using a small fillet having just used it on a job,
it worked
V5.


Steve


(Brian Gillespie) #18

RH-38738 is fixed in the latest WIP