Filesize exploding


Added is a Rhino file of 1.434kB that when saved as an Iges file explodes to more than 156.000kB.
Can anyone tell why this is happening?


DirkLayout.3dm (1.4 MB)

Hi Dirk - iges is a text format, very inefficient as far as file size on disk goes, compared to binary.


Hallo Pascal,
I’m using Rhino quite a bit to do preliminary work for Cadmatic, a program we use on the yard I work.
To get a Rhino file to Cadmatic, someone found out in the past that it should be done by exporting the Rhino file to an Iges file, import this in Autocad 3D, and exporting this as a Cadmatic 3dc file. Never thougth that there could maybe be easier ways.
I tried a few things today.
First I exported the Rhino file as an Autocad 3d file. Nice file size, approx. 550 kB.
This file I imported in Autocad 3D, still no problem, filesize still approx. 600 kB.
But then I exported it as a Cadmatic 3dc file, and it went up to some 36.500 kB.
Then I found out that Autocad also takes Rhino files.
Tried this, but allthough I get the message that the file has been loaded, I don’t get anything to see.
Maybe you, or someone else has an idea what’s happening.
Kind regards,

Hi Dirk - does Cadmatic read step files? These are also text based, but carry a lot more information than iges, in particular solid (joining info) so it might be handy in any case, but it would also go direct, bypassing the extra Autocad step.


Hallo Pascal,

After a discussion at the yard, I found out that the way to import whatever files into Cadmatic has to be through Autocad 3d.
The strange thing is that Autocad says it reads Rhino files, but I don’t get a result after import.
So I’m going to try to find out why this is happening first.



Hi Dirk - see if they read V5 or even V4 versions of your file (SaveAs/Export to an earlier version)


Good day Pascal,
Had several tries, but for some reason Autocad 12, at least the version we have got doesn’t eat Rhino 5. It says the file is loaded, but when I try to see it, nothing’s there. As far as I know Autocad 12 and Rhino 5 are from the same year.
When I go down to Rhino 4, Autocad reads the file, and I can see what I made in Rhino, but when I transfer it to Cadmatic I get several messages saying that errors have occured. Tomorrow we will have a look at what is left in Cadmatic.
And after that we will have to get in contact with Autocad to see or they now more about this.