File won't open

Worked on a file (about 10MB) and completed a session after just Boolean Unioning many small details to the main body. All seemed fine, but now when I try to open the file, I just get the little spinner going on forever (over 5 minutes) without opening. Any tips? Running Rhino 6 on OS 10.14.6

Did you save the file after working, and are trying to open the saved file? Or are you trying to save after working?

Hello - it seems at least possible from your description that there is a meshing bottle-neck someplace - is there any indication that Rhino is attempting to create meshes? It’s harder to tell on a mac, but see if the command area at the bottom shows anything. You can also try hitting Esc, which, if that is the problem, may stop the meshing process and open in wireframe, maybe.


Saved on closing. Now won’t open.

George Sebastian-Coleman

Hitting escape worked. Screen was blank, but as soon as I hit escape it popped up in wire frame. Thanks.

Hello - so the thing now is to locate what is not meshing cleanly - if there are multiple objects, please try SelBadObjects - if that rings anything up, hide it and see how shading a view works. If there are no bad objects, try hiding half at a time and shading the view to see if you can narrow down the bad guy. If none of that works, please SaveSmall and send the file to to my attention, along with a link back here in your comments.


No bad objects, but figured out the component causing the issue. Ran extract surface from the Solids menu and that seems to have cured the issue. Thanks!