File won't generate gcode on replicator g?


#1

Hi I’ve created a model in rhino, I’ve already 3d printed it once. But ive since changed it and it now won’t generate a g code in replicator g, I can import it into replicator g and makerware. But it will just spend ages and not generate gcode.
it has gone from a 7mb file to a 300mb file when I export it as an stl.
I simply don’t know why it’s doing this? Any suggestions?


#2

Sounds like your stl settings are too fine… Your replicator software might not like the file size…

–Mitch


#3

if I lower the poly count will I lose masses of detail? How can I preserve the detail of
My model?
Thanks for your help


#4

I don’t know - each model is different. The idea is to have more polygons in high detail areas and less in low detail areas. If you have high detail everywhere, then you will likely have a massive stl file anyway. Then you need professional 3D printer software that is able to deal with large file sizes.

Don’t forget your 3D printing system has a minimum resolution - trying to preserve more detail in the stl than the machine can physically produce is useless.

Here are a couple of WIKI pages on meshing parameters and RP

–Mitch


#5

Hi, i have tried everything to generate a gcode of my model, i just dont understand why its doing this? i dont suppose you gave any more suggestions of how i could discover whats wrong?

thanks


#6

Since I don’t have the software for your 3D printer, there’s no way I can test what’s wrong, although I still suspect the file size is just too big… All I can do is offer to run it through my software if you can provide a link to the file…

–Mitch


#7

Here is my file, it is my first model on rhino, like i said i have managed to 3d print it in the past, but ever since i altered the bottom to create the geometric edging, generating the gcode in replicatorg iant wokring.
the way i created the bottom edging was by creating a separate shape as a tool then boolean 2 objects and that left me with the desired look

thanks again :slight_smile:


#8

hi xdelucax and Mitch,

i think the generation of gcode fails in ReplicatorG and Makerware because of the model, which contains a few self-intersecting volumes, naked edges and at least one floating surface which cannot be sliced.

@xdelucax, a few steps which may help before you export your models out of Rhino for 3d printing:

  • make shure the model is made up of closed polysurfaces which don`t intersect or have naked edges. To find out if your model has naked edges, you might use commands like _ShowEdges and _SelOpenPolySrf in Rhino, then close these gaps.

  • when extruding shapes like the figure in your file, make shure the source curve is a nurbs curve and not a polyline made up of many small line segments. You can use _FitCrv to fix the figure`s shape curve, eg. with a tolerance of 0.01 and angle tolerance = 5 and degree = 3 to clean up the shape into multiple curve segments, then extrude this into a closed volume.

…to create a volume out of the other parts, i´ve booleaned everything together into one part. GCode generation worked fine then with makerware, i´ve used the attached mesh settings to export as obj file.

cleaned up file: xdelucax.3dm (2.0 MB)

mesh settings i´ve used to export:

good luck,
c.


#9

Hi, Thank you very much for your help, it seems ive still got a lot to learn, i would still like to see if i can fix the my original model, just so i know for the future.

thanks again


#10

Thanks for jumping in Clement, I didn’t have time last night… As Clement said, your object is composed of a bunch of surfaces and polysurfaces that do not form a closed shell with no holes or naked edges. That is essential for a 3D print. Some 3D printing software is tolerant of small gaps, but in the case of your file, there is simply too much confusion for it to figure out what to do…

Just for fun, I exported the whole thing - open surfaces and all - as an stl and threw that into Magics - stl repair software. After a few runs through, I was able to get an stl which would run in my printer software (attached). It’s still kind of a mess with some interior walls and overlaps that shouldn’t be there though, but it will print.

–Mitch

deluca.zip (797.8 KB)


#11

Wow, thank you very much for your help. i would like to ask, is there some sort of “analyse” tool in rhino that can help me identify the flaws in my model?

thanks


#12

Selecting the object and looking in Properties>Details (or calling the command What) will give you some detailed info on the object. Specifically it will tell you if the object is closed or not. You can also use SelClosedPolysrf to see if it will select.

If it is not closed, then under Analysis>Edge tools>Show edges you can turn on the edge display and set it to naked edges. That will show you the edges that are still open.

Then maybe [the information on this page][1] will help…

–Mitch
[1]: http://wiki.mcneel.com/rhino/faqclosedsolids