File will not open

When I try to open this particular file I get this message:

/Users/Timmy/Model Stuff/Jaguar Model/JaguarCAM.3dm is not a Rhino file.

I’ve tried Rescue3dmFile and when I use the analyze button I get this:

====== FILENAME: /Users/Timmy/Model Stuff/Jaguar Model/JaguarCAM.3dm
ERROR Read3dmStartSection() failed

None of the other options appear to work.

Any Ideas?



Based on my experience with Rhino, you are likely to have one or two situations:
1 - You have a 3dm file that is so badly damaged that there is no readable data in it
2 - Someone renamed a different file and added the 3dm file extension, so it never was a Rhino file.

My guess is the latter is the most likely scenario.

You can open a 3dm file in a text editor.
If it ever was a Rhino file, the start section will look something like this:
3D Geometry File Format 50KRhinoceros 5.0 - English Evaluation, build 0000-00-00 - (compiled Mar 24 2015)
SDK Version: 201103025.201412015
OpenNURBS Version: 201412015
3dm Version: 5

In either case, there is nothing to recover.

You can try renaming the file to different extensions - Kind of a crap-shoot but there are some obvious ones to try - I’ve renamed a file to .zip and that turned out to be correct…


Okay thanks guys…not encouraging.

Definitely not a renamed file…it stopped just stopped opening.

The file is just shy of 500mb. Luckily most duplicated elsewhere.

Do you have a .3dmbak file in the same folder where this 3dm lives? This should be the last healthy save and can be opened directly. If it does, use File>SaveAs right away to save it out as a new version. It’s sounding like the file got corrupted somehow.

I am having the same problem.

Has anyone figured out a way to solve it? thank you

What have you tried so far?
Did it used to open without problems? Is there a backup file?

Apparently there is no backup file. At least there is no .bak file next to the original file in the folder.

The file was closed normally. When closing I was asked if I wanted to save the changes and I clicked “revert changes”, as none of the changes I had made where significant enough to save.

I tried to open the file hours later and Rhino said that the file was not a Rhino file.

I have tried to “rescue” the file, but nothing happens when clicking Recover. When analysing it i get this : ERROR Read3dmStartSection() failed.

I must say I´m working on Rhino for Mac, if this helps in any way.

Hey man i had the exact problem of yours, i am also using Mac rhino and also "revert changes"
and shit just went down…
said it was not a rhino file (check
rescue file but nothing happened (check
ERROR Read3dmStartSection() failed (check

Have you found the solution yet?
It would be great if you did… thanks man

Yes, “Revert changes” corrupts the file. Argh.

I mean seriously, this is bad, today I just opened some files to copy some previously drafted parts, and when closing it I naively clicked on “Revert to changes” – now my file cannot be opened, I have to dig it from Time Machine to find a usable state of it, please do something ASAP, because threads are 2 years old.

I occasionally find .3dm files like this which were 100% working Rhino documents, not renamed, I suppose they were going through the “Revert changes” route.

Extremely frustrating.

@furtonb - this thread was relative to Rhino for Windows, you are on Mac and this is a different issue, please post a new thread in the Mac section of the forum…

Sorry, I was in a rush, and the last replies were also related for Rhino for Mac…

Fortunately the issue since then was either solved, or became less frequent, but lately I cannot recall having to deal with it.

Hi all,

I’m having the same problem, I saved a very simple rhino file 2 days ago and now it says the file cannot open because it’s not a rhino file, does anyone know how to fix this?
And the same problem happened when I was trying to open an older file, which is also definitely a Rhino file…very confused!

Hello- if you can, please post the file here or send to with a link back here in your comments.

Please also run the SystemInfo command in Rhino and copy/paste the results here.