File size limit on PictureFrame?


#1

Is there a limit on the size of a file that can be loaded using PictureFrame?

I have a pretty big png file – about 1.2 Meg. When I run PictureFrame and attempt to load this file, Rhino 5 crashes. The crash is repeatable.

Is file size the problem?

Thank you for your insights.

Michael


(John Brock) #2

It shouldn’t crash but that’s a pretty ridiculous file size to use for a PF image.
I wouldn’t use an image over about 1024x1024 pixels. There should be no limit but there certainly is a practical limit.

Can you please send the big image so we can test it here?
There’s a file upload tool on the Support page on the Rhino Web site.

Use the same problem description you did here so the receiving tech will know what to do with it.

Thanks


(Dale Fugier) #3

Hi Michael,

Its possible that the crash is caused by your video card. When you’ve crashed, have you submitted your crash reports when prompted?


(John Brock) #4

The image worked fine here.
I replied in an email message.
Dale may be right. You could have an unsupported video card, a buggy driver, or be running under virtualization in OSX.


#5

Thank you for your interest.

Yes, I submitted a crash report yesterday. Today, at John Brock’s suggestion (above) I uploaded to Support the png file I had attempted to incorporate in a PictureFrame.

Michael


(John Brock) #6

Run the Options command and go into View - OpenGL.
Take a screenshot of the settings on that page and return the image in a reply.
Maybe we’ll see something there.

Thanks


#7

Hello John,

Thank you for your time.  Here is the information you requested.

Rhino:

Version 5 SR9 64-bit

(5.9.40609.20145, 6/9/2014)

Commercial

SN: 4-1502-0101-100-0003944-44989

Bongo 2 installed.

System:

Display card:

AMD FirePro W5000 (FireGL V)

When Rhino 5.0 came out, it supported the FirePro W5000.  The first
few updates of Rhino 5, however, had problems with it, so for a long
time I stuck with 5.0.  This problem was solved in the third or
fourth update, and since then I have updated Rhino routinely. 
However, one possibility is that something was lost in the most
recent update.


Regards, Michael


(John Brock) #8

Hi
I suspect the problem is old video drivers for your FirePro W5000.
Here’s a link to new drivers that were released about a week ago:
http://support.amd.com/en-us/download/workstation?os=Windows%207%20-%2064#catalyst-pro

Please download and install them. See if that solves the problem.

Good luck,


#9

Thank you for your suggestion.

The AMD driver utility shows my current driver is up to date. However, in scanning their site, I found the recommended card for SR9 is W5100. Mine is W5000. Wonder what the difference might be.