File Corruption: MatchSrf


#1

(MacRhino v510, OSX 10.7.5)

MatchSrf just corrupted my file. Did not crash the program, but overloaded the processor for about 3 minutes and a number of things then went awry with the display. Worse, all elements hidden on the active layer were gone after the command – I got what looked like a tiny little point which I could not zoom onto. After saving and reopening, my file looked like this – note the “RhinoView” labels in the second header bar. Nothing would show up in the three gray windows, despite all manner of trying to change these views.

I first suspected corruption of preferences, but creating a new file seemed to worked as expected. The good news is that “Versions” (thank you Apple and RMA!) saved my bacon and I was able to recover the prior work.

I’m not entirely sure what went wrong (I may have run the command on a trimmed surface?), but maybe there’s a bug lurking somewhere in this command?

Enclosed is solely the geometry (three surfaces created by BlendSrf from adjacent planar surfaces) two of which I tried MatchSrf on. At this point, I can’t recall which two elements I used the command on, sorry. If RMA wants to take a peek at the larger file, just let me know.

~Dave
TEST_MATCHSRF.3dm (71.2 KB)


(Marlin Prowell) #2

I see you are running 10.7.5, and I assume you are doing so because you are running on older Mac hardware.

This is definitely a badly corrupted Rhino file, and, from your description, I’m going to assume it was caused by a hard disk write error. Hard disks are mechanical devices, and they all eventually fail. If you do not already have Time Machine backups, start doing that immediately. Like, today! If you do not also have your hard disk cloned to an external drive, start doing that immediately.

You are about to lose all your data on your internal drive.

Been there, done that. It’s not fun picking up the pieces when you don’t have backups.


#3

@marlin: Hmmm… How confident are you that this is a hard drive issue? Several problems occurred immediately in the file following the command, prior to any save. And the command took many minutes to execute, forcing the fans on while performing what should have been a simple operation. Maybe I’m missing something but, I’m not sure where the hard drive entered into the equation?

Hard drive: I’m using a 500 gig SSD from Other World Computing (Mercury Electra 6G), that, believe it or not, was just replaced a couple weeks ago due to failure of the previous drive. Is this one going south too!!! Any recommended software to test the hard drive health to verify if this is the issue? (And thanks for the reminder to backup – which I do religiously).

Hardware: I’m running a late 2011 MBP, 2.5 GHz Intel Core i7 (the last of the 17" Lapzillas…sniff!) with 16 gig of ram. While not as fast as the newest MBPs, it’s been a pretty stout setup.

Yes, I could upgrade to Mavericks, but, quite honestly, I fear unintended consequences with Adobe CS5 Suite (and I have ZERO interest in their new subscription [extortion] package), as well as other programs I might want to use occasionally. (Yes, my once fervent days of “early adoption” are long gone—especially when it comes to OS upgrades. A hundred times bitten, twice shy!!!)

~Dave