[FBX] Exporting multiple cameras issue?

As shown in this screenshot Rhino is exporting FBX mesh with multiple cameras. More than expected.

I’m doing something wrong or is a Rhino issue?
How to avoid this issue?
Is there a way to export without cameras and lights?
Thank you so much

I think you can do that with: Save As… > Check Ensure Save Geometry Only > Pick MotionBuilder (FBX), press save

Is there a way to delete this cameras?

Once you check: Save Geometry Only you’ll get an FBX file that contains no cameras.

image

1 Like

Yes, I’m doing that as you mention before. The problem is that my big Rhino file is full of cameras.

I use to import the FBX to double-check the integrity of the UV mapping using an automatic custom button. Now, since exporting “Save Geometry Only” option by default is off and Rhino does not conserve in memory my last action, I finish having hundreds of cameras. There is no way inside the automatic exporter options to tell Rhino to “Save Geometry Only”.Since my Rhino file is big is not simple to copy and paste to a new clean Rhino (I’m afraid of losing data).

So I need to find two solutions: One is how to export FBX automatically telling Unity to “Save Geometry Only”. And I was thinking Grasshopper for that.

Meanwhile,
Is there a way to delete cameras (as shown in the screenshot) out from my existing project?

You can script the Save command by using the dashed version:

-_Save _GeometryOnly=_Yes N:\MiscFiles\Test.fbx _Enter _Enter

This will save to a Test.fbx with the meshing options as they currently are.

To figure out what you all can set just use -_Save on the command-line.

1 Like

And Tim Hemmelman suggest using Open instead of Import FBX (in V7 there will fix RH-54785)

Tim Hemmelman: you can run NamedView, select them all and delete them.

@nathanletwory ,

Tim explain the correct way is:

Somehow I was putting _geometryonly=_yes not in the correct order.

If you are using a button you must put the _geometryonly=_yes before the file name or that parameter is passed to the scripted UI for the plugin, and ignored. This works.

! -Export _geometryonly=_yes "D:\RhinoTest.fbx"

Thanks, both!

Answers by Nathan and Tim!! To resume: Is there a way to delete these cameras?
Yes, you can run NamedView , select the cameras and delete them.
How to avoid this issue? Probably you are exporting and importing the cameras. Enable Geometry to export without cameras. if you are using a button with a command line, in Windows

to export use:

! -Export _geometryonly=_yes "D:\RhinoTest.fbx"
enter
enter

and to import use:

_Import "D:\RhinoTest.fbx"
enter
enter

If you use C: drive, will not work.