Faro arm connect


#1

Hi!

Two questions:

  1. I’m having trouble connecting my RS232 serial connection Faro Gold Arm in RH5 SR14 64-bit (5.14.522.8390, 2017-05-22)

When trying to connect, Rhino keeps telling me that it can’t find the FaroArm.dll file.

But the file is there and the plugin is activated.

Is this a W10 problem?

  1. This is a very old arm/digitizer. 17 years infact!

When sold it had a software named caliper3d.exe. This sw was used to calibrate the tooltips and could be used for some simple measurements/point collection. I only need it for calibration and basic test purpose.

However, Windows has outgrown this exe. It won’t run/connect anymore. I think Windows XP was the latest working os with the Caliper3d i have. Is there a workaround?

Is there any cost effective remedy to this? Buying Faro CAM2Measure would be one, but it is out of my league/economy.

I downloaded a three month trial of CAM2Measure and it all works. It seems like the sw that handles the arm is “driver-like”, but I suppose it stops working after the trial period.

Anyone?

Thanks in advance.

HOP


Faro Arm plugin wont work in 64bit Rhino (FaroArm.dll)
Faro G08 Compatibility
(GTPrototype) #2

I’m traveling down a similar path with my RS232 Faro Arm silver (7DOF). I plan to use Rhino although I have no experience interfacing with it yet. I’D love to hear how you’re progressing.

Several things I have found out along the way that you might not know:

  1. Faro Caliper3D came in two versions, 16bit (Win 3.x) and 32bit (Win 95, Win NT).
  2. The 32bit version will work in Win 764 however the installation program will not run.
    2a) I believe both versions use a 16bit installation program which causes the installation problem with Win 764.
  3. You can unpack the program by installing it on Win XP and copy into Win 764
  4. you will also need to copy farocomm.dll.
  5. The program will run fine in Win 764 after you register the dll file.

-dale


(GTPrototype) #3

When installing Caliper 3D I got the error message: “FAROCOMM.DLL Missing or Corrupted” I had to register the DLL file after copying it to the appropriate folder. I don’t have any experience with win 10, so I can’t offer any relevant instructions except that it will probably have to be done from an elevated command prompt. Best to search how to register a dll or regsvr32.exe. Hope this helps.

-dale


(GTPrototype) #4

I finally got the Rhino 6 evalaution installed. I get the FaroArm.DLL error also. I located and tried to manually register the DLL with no luck. I’m unable to get Rhino to communicate with the serial FaroArm. The serial FaroArm works with Caliper 3D and Cam2 just fine.

I have a serial microscribe 3DX which seems to work with Rhino although the accuracy / scaling isn’t correct. Being a Rhino newbee I suspect I need to learn how to calibrate correctly.

Seeing how the serial FaroArm works with the other programs and the serial Microscribe works with Rhino I don’t believe it is a serial connection problem. I believe there is a problem with the Rhino Plug-in that needs to be addressed.

-dale


(GTPrototype) #5

I’m communicating with the Plug-in development team to hopefully get this resolved. I will post the results.


(GTPrototype) #6

Serial FaroArm UPDATE:
The development team has identified the problem as a 32bit / 64bit conflict with the dll. At their suggestion I’ve installed Rhino 5 32bit and I’m happily testing out the serial FaroArm with Rhino. It sure is nice to be using the FaroArm to model directly. I feel like a young boy on Christmas day!


#7

I went at it again after purchasing RH6, with no better result :tired_face:

I think that McNeel must compile the “digitize_Faro.rhp” for RH6, for this to work.

Admin, can you raise this question to the relevant developer?

Regards, HOP


#8

Note: I tried a completely different software aswell. It has the FaroArm.dll file resident in its system folder.

I even pinched that file and copied it to both Rhino, W10/sys32 and /sysWOW64, along with registering it.

This software was able to use the Faro arm without any problem in W10. So again, the problem ought to be that recompiling in RH6 is needed but has a low priority.


#11

And yes @gtprototype , RH5 32 works for me too. But I hope this will be fixed since the Faro Digitizer tool exist and is selectable in RH6.


(Tim Hemmelman) #12

We have a 32 bit dll file for the Faro serial digitizer. In order for this to ever work in V5 x64 or V6 (which is only x64) we’ll need a new x64 dll from Faro. You can try contacting them and see if you can convince them.

Tim


(Tim Hemmelman) #13

There is a new bug report to remove the serial version of the plugin the V6 Rhino product. https://mcneel.myjetbrains.com/youtrack/issue/RH-45377 I will not get rid of the project though in the event that you can persuade Faro to send us a 64bit version of their dll. It’s fairly trivial to put back in there if that ever happens.

Tim