False file modified?


#1

Is anyone experiencing Rhino asking to save when nothing is done in V6? I don’t have anything in “Run these commands every time Rhino starts,” I am loading some scripts on start, but none are called. I am using my own template file, but that shouldn’t do anything, right? These are the Plug-ins that don’t ship with Rhino.

One interesting thing is the dialog asking if I want to save changes is titled “Undefined WIP”

Thanks,
Sam


(Nathan 'jesterKing' Letwory) #2

Most if not all of those plug-ins are shipped with Rhino. I have created a YouTrack issue to track the status of this bug:

RH-37710

Thanks for reporting.

edit: I don’t know about the file modified issue.

/Nathan


(Pascal Golay) #3

Hi Sam - is your template file in V5 format by any chance?

-Pascal


#4

Ooo, good thought, it is. Oddly though, I don’t seem to be able to change it. I’ve saved my template out as V6, but when I try and change the template file default, it doesn’t stick. As soon as I close and reopen Options, it is set back to the old template file. Any advice there?

Thanks,
Sam


(Wim Dekeyser) #5

(Pascal Golay) #6

Hi Sam -

This is a bug, probably the same as -

But, just to be sure - is the old template file in the default V6 template location, or had you set a custom template file location in the past and now cannot change it? Either way, I think this is all part of the new Settings file stuff…

-Pascal


#7

Drat, thanks gents.

My templates (both my old V5 and my new V6) are in MyDocuments, so not the default location.

Thanks again,
Sam


(Pascal Golay) #8

Hi Sam - thanks - I just want to be sure I’ve got all the bugs here — I can change the default template file within my template file folder, but I cannot designate a different template file folder. Is that what you get as well?

-Pascal


#9

Over here, no. If I change the default to one within the template folder (C:\Users\[USER]\AppData\Roaming\McNeel\Rhinoceros\6.0\Localization\en-US\Template Files) the next time I open Options, it is set back to my V5 template file in My Documents.

As a work around, I tried renaming my new v6 template to the v5 name that is stuck as my Default template, and I’m still getting the do you want to save changes on an unchanged file.

Sam


(Pascal Golay) #10

Hi Sam - and this is on just opening Rhino then closing the file or Rhino, correct?

That actually seems like the same as here- I cannot change the template folder and if I try to change the default template to one that is in a different folder, that also fails. I can change the default to a different file in the current template folder.

At any rate, can you please send me the template you’re using, I’ll see if I can reproduce the file changed error.

thanks, sorry for the hassle…

-Pascal


#11

Correct. As far as I am aware, I nor Rhino (start up commands, etc.) are doing anything.

(Really boring) template file attached :wink:

SamTemplate.3dm (132.6 KB)


(Pascal Golay) #12

Thanks… not happening here, of course. Still poking…
@JohnM - any idea? Sam is asked if he wants to save the file just opening and closing Rhino.

-Pascal


#13

Still confirming, but right now it looks like it is being caused by having the material editor open when Rhino opens. I’m guessing my template has no materials, and one is being created.


(Pascal Golay) #14

You’re right, it does create a material and yet I do not get the Save question…

-Pascal


#15

Its Notes! I had material editor and notes docked together, so I assumed material editor, but it appears over here at least, having Notes open causes the file changed warning.


(Pascal Golay) #16

Hmm - Darn. I still don’t get that file changed but I see that notes that are saved in the template are not read in as Rhino starts up using that template and are read in on New > Same template file. Another bug there but not the one you’re seeing…
https://mcneel.myjetbrains.com/youtrack/issue/RH-37745
-Pascal


(Pascal Golay) #17

Hi Sam - I just installed an auto-update internal latest build… and I just noticed I get the behavior you describe. There’s hope…
@SamPage - John has one more tweak to add before I can test this but I think the change will make it into the next WIP, this afternoon of all goes well. Thanks for the report…

-Pascal


(John Morse) #18

RH-37740 Changing the default template folder now works correctly.

RH-37745 Has also been fixed which address the notes in templates at start-up issue. I noticed the notes changing the document modified flag when fixing this bug and added some code that should make this better. The control was updating the document notes when losing focus causing the document modified flag to get set. The notes control now compares the its value with the documents notes property and only updates the notes when the values are not equal.


(Brian Gillespie) #19

RH-37710 is fixed in the latest WIP