Failed to save Rhino 6 file


(Contact) #23

So it finaly crashed till i was trying to export my drawing in DWG…

I noticed than i copy/paste a dimension which was working on Rhino 5, but i was able to save few times after.
I started to have the issue til i was doing some work on some layout.
I had also a lot of .tmp file instead of my save in the same location i have the file…

Can we something about ?
Pretty scared to restart drawing now.


(David Eränen) #24

Tagging @andy.


(Andrew le Bihan) #25

Did you copy the dimension from a running instance of Rhino 5?


(Andrew le Bihan) #26

The absolute best thing you can do to help us is to figure out how to repeat the problem. If you have steps we can follow here, I’m certain we will be able.to fox the problem in 24 hours.


(Contact) #27

So far i had the problem 2 times on the same files. First time 3 days ago, and second time few hours ago.
In term of dimension, i opened a Rhino5 file into Rhino6 and copy paste to my file.

Since the problem, i reopen the file from the last save, and did a new copy to move on.
i really hope to do don’t have the same issue, but will try to keep in mind what i do if the problem restart.


(Contact) #29

Hi there,
i have again the same problem of “failed to save” on another file.
And this time i didn’t copy paste anything from an old file.

Still not able to copy my drawing to another file or to export.
And I can’t even copy paste in the same file.
For information, it’s another computer Rhino6 commercial and Windows 10

I am thinking : is it connected to the last update ?


(Andrew le Bihan) #30

@bunker-palace

We don’t think it’s related to the update. Do you still have your Rhino open in that state?

  • Andy

(Contact) #31

nope… it eventually crashed till i was trying to export/copy/save what i did without success.
you have something i mind i should try next time ?


(Andrew le Bihan) #32

@bunker-palace

Two things:

  1. If you know the steps you used to get to that point, send those.
  2. If you get the save error, and you would be OK with me doing a remote debugging session on your computer, please leave it in that state and contact me either through Discourse, or directly on andy@mcneel.com
  • Andy

(Contact) #33

Thanks !

For the 1. i will check, but so far i didnt’ notice what i did which can do this situation (will try to check)
And for the 2. i will be for sure ok

Thanks again !


(Stanity Now) #34

Hello,

Just wanted to weigh in. Had the same error “Failed to save Rhino 6 file… Writing to disk or storage device failed.” In addition, two other Rhino 6 colleagues of mine had the same issue. Upon their advice I managed to save to Rhino 5 version. Tho I dread opening it now. Will leave it for the morning.
I had been annotating drawings in layout and model space. No dimensions pasted from Rhino 5 that I can recall. But that kind of contamination is hard to control… older drafting templates might have Rhino 5 dims, or files from colleagues.
Dunno what to say. I have read this discussion above. Wish there was some finality to it. Just wanted to have my voice heard to underscore the need to have this issue looked into thoroughly.

Stan.


(Gert Wuyts) #35

Hello Contact,

I had the same problem several times
One time I was able to save my drawing to Rhino5 format.
But the last time I had to recover my Autosave-file (Settings).
I let it save every 5 minutes.
I didn’t try the ‘copytoclipboard’ command yet. It seems to me also a possible way out.


#36

is there any news about this?

copy to clipboard doesnt work for me in this situation. I was able to rescue my work using the rhino5 file (even though this sometimes seems to mess with font sizes, modelspace scale or smth). i dont know if its related to me saving onto a folder that is synchronized to my NAS, but its the only program showing this behaviour. after restarting rhino 6 the problem disappears for the time being.

i’m happy to help if i can in any way, this is happening frequently enough to be a major nuisance/if not a problem (so far i was lucky enough that the rhino-5 save always worked)

Capture


(Andrew le Bihan) #37

Fertig

Looking at what’s under dialog, it looks like you’re fiddling around with dimensions. Does that sound right?

Here’s what you can do to help:

  1. Figure out a specific set of steps that is repeatable that gets us to this dialog box. Ideally, this would take the form of a 3dm file that we can load, perform a few steps, press Save and the dialog comes up every time.

  2. If this is not possible, but you do still manage to get into this state every now and then, you could allow us to remote control your machine, installer the remote debugging tools and figure out what’s going on. For that to happen, you will have to leave Rhino open in this state, and contact me (andy@mcneel.com)

  • Andy

(Nbarnes) #38

I am working with a process to create dimensions using the grasshopper plug in Elefront (updated to latest version as of May). The Rhino file has been saving intermittently to Rh6 but I can consistently save down to Rh 5.

image


#40

I had this issue a while back, you can see here, I use Make2D a lot with dimensions and text etc, was able to save as V5 at the time, it hasn’t happened since


#41

Hi, I meet this problem today too. It was scene with VfR 3.6 and with Layouts… Any try to save as R6 file in any place failed. Save as R5 was possible. So solving was: save as R5, open in R6 and save again as R6.
I have Rhino 6.4


#42

And when we are talking about saving, sometimes in autosave it freeze Rhino for long minutes…


(Chris Dardis) #43

I just had this bug present itself. I don’t have a file I can contribute to help replicate the bug because… it didn’t save :).

I did notice one strange thing before the save error. I tried copying an object (open curve) and pasting it, but it the paste command kept on pasting an old object from the clipboard, not the new one. I could not get copy paste to function correctly after that, either cmd, gui or shortcut. So I tried to save file, seeing if a restart of rhino would clear the issue, and ‘Failed to save’ etc cropped up.

Sorry I don’t have more information. FYI. I tried same steps again and can’t reproduce.


(Pascal Golay) #44

Hi Chris - in the folder where you were trying to save, are there .tmp files, with names like the file you had open? If so, can you send us one, or preferably several of those? Typically, they are not very big - 600k or so perhaps.

Were you using dimensions in this file?

thanks for the report,

-Pascal