Failed to save Rhino 6 file

@pascal Since posting last time i’ve investigated my files a bit further and I definately think it’s something related to visualArq? All files I can find that do this are using the plugin in some capacity… :confused:

Have you got any ideas as to why this plugin inparticular would cause saving issues?

And without going too far off track the only reason I actually use this plugin is for its “hidden” viewing mode which allows my CAD drawings to be printed in vector, is this not something Rhino could implement?

Hi -

Does that mean that all files that are created in Rhino without having VisualArq enabled are saved to the server without any errors?

It is something that has been on the wishlist for a long time - RH-11615 - I’ve added your request for this feature.
-wim

1 Like

No unfortunately it still won’t save even after I turn all plugins off.
Thankfully i’m in a position where i’m not working in a large team so I can work off my desktop but if other people were relying on this model on the server i’d be in hot water, any other suggestions to avoid this happening in future?

And thanks for that! glad to see it’s in progress just hope it’s not another one of those 6 year ones :stuck_out_tongue: sadly as much as I love rhino, I don’t know how it can be considered a true CAD application when it doesn’t have 3D to 2D vector printing.

Hi there. Is a file being created in the location you are trying to save? Probably with the extension “tmp”? If so, could you send it to us?

Hi @andy thanks for that, I’ve run into this problem again today and have uploaded the Rhino file along with the “tmp” file here:http://mbf.co/uhpzEy

@fsalla I’ve noticed again when I run into this issue it is when I enable the plugin visualarq and Tibidabo, are you aware of any other users running into this problem on your plugin?
Thank you

This looks like a plug in problem - either VisualARQ or VRay. I would suggest disabling each of the following plug-ins and trying again:

File: C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Tibidabo.rhp
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\VisualARQ.rhp

It looks like one of these plug-ins (difficult to tell which) is “soft crashing” (throwing an exception in the parlance) when writing its user data.

Yes definitely VisualArq, ever since I started having this issue I disabled VisualArq/Tibidabo and the problem went away.

@enric & @fsalla i’ve noticed in this thread: VisualARQ Objects Disappearing/Deleted!
There may be issues when running Vray and VisualArq simultaneously, do you think this has anything to do with it?

@enric - another Visual Arq one for you - can you take a look?

-Pascal

Hi @jcmv_design,

That error is already solved in recent VisualARQ and V-Ray versions, so as long as you have both plug-ins updates, I think the problem you have is another issue.

Can you share one of the files that fails to save to a network server? Send it to visualarq@asuni.com.
Does it happen every time you try to save?

Enric

@enric Thanks, i’ve sent the file to that email now. Yes the error happens everytime I try to save (even on the desktop), unless I turn off VisualArq.

Hi Jack,

I cannot reproduce the issue. Here are the steps that I’m doing:

  • Open 3DM file that you sent to me.
  • Run command “_SaveAs” and write it to “Desktop”.
  • No errors.

I’m using the following versions:

  • Rhino 6 SR24 (I’ve also tried SR25)
  • Tibidabo 18.15.5
  • VisualARQ 2.7.5
  • V-Ray 4.00.01

I guess that there is something else that is causing this error.
Which plug-ins do you have installed?
Which Grasshopper add-ons do you have installed?

Can you try the following steps:

  • Update Rhino 6 to SR24 (https://www.rhino3d.com/download/rhino-for-windows/6/latest)
  • Update VisualARQ to 2.7.5 (https://www.visualarq.com/download/update/v2/rhino6/)
  • Try if the error persists. If so continue:
  • Disable all third-party plug-ins except Tibidabo and VisualARQ.
  • Disable Grasshopper (I want to avoid all GH add-ons)
  • Restart Rhino 6.
  • Try if the error persists. If yes, contact me, and we’ll schedule a remote meeting for next week so I can remotely debug your computer to see what’s going on.
  • If not, then try to enable GH and the rest of third-party plug-ins, one by one, until the error comes back. Then let me know which plug-in and I’ll try to reproduce the error and see why VisualARQ and that plug-in are causing the error.

Enric

Thanks @enric, updating VisualArq seemed to allow me to save on my desktop.

I’ve been running into this issue a lot when I have to save it on my work server but unfortunately I can’t test it properly at the studio right now due to Covid. i’ll keep you posted and reply when I get a chance to test it there aswell.

Thanks again

Just wanted to update everyone on a recent run in with this issue, on an educational license of Rhino 6.

I tried a lot of the solutions above but in the end it was an update to windows security settings that was stopping me from writing to my documents folder ( I could write to my desktop but not anywhere else, leading me to believe Rhino, along with other software, was being blocked )

My solution:
Virus & Threat Protection > Under the Ransomware Protection Header, select Manage ransomware protection and disable “Controlled Folder Access”

image

This menu can also be accessed through Virus & Threat Protection > Virus & threat protection settings > Controlled Folder Access > Manage Controlled Folder Access

Sorry for reviving old thread but I figure a lot of people who are updating windows regularly will hit up against this issue. Here is my build info:

Edition Windows 10 Home
Version 20H2
Installed on ‎12/‎7/‎2019
OS build 19042.804
Experience Windows Feature Experience Pack 120.2212.551.0

2 Likes

Thanks for that update.

-Pascal

1 Like

Thank you. This solved it for me.

1 Like

YOU ARE A GENIUS! LOVE U :grinning: :grinning: :grinning: :grinning:

Hi everyone,

Picking this back up again, because I just started getting the error for the first time today. I tried the Virus & Threat protection trick noted above but it did not solve for me. Any other solutions that the community has found?

I have not run any grasshopper definitions in this file, and the only plug-ins I have loaded are Twinmotion 2020 & Enscape.

Thanks in advance for any help!

image

I have been wondering how to test this without recreating it. I think the best option would be trying to save it to a public folder (desktop is usually public or you can create one) and checking if the error is the same. You could also try saving to a usb drive.

Thanks for the reply @ewilli22. I’ve had it reoccur once today. I have a suspicion it has something to do with the file being in a dropbox folder. I believe this was mentioned in an earlier post on this thread. I’m now read/writing to a local folder and will post if the issue happens again.

I find that the security system in windows is getting more and more picky, especially with less popular programs like Rhino so I am glad we are not shut out yet. You could always try changing the permission structure on a file and saving to it and see if that makes the same popup