Failed to read binary faces, cannot continue

I’ve been landmarking .ply files in Rhino 7. I’ve never had this issue until today.

When I try to drag and drop a .ply into the UI, the program loads for some time, then returns the message: Failed to read binary faces. Cannot continue. If I try to import the file manually, I receive the same error plus “Error importing file” followed by the file name.

I’ve tried to compare the non-working .ply files against the working .ply files and can’t find anything glaring. Is this likely a file issue and not a Rhino issue? I’m fairly new to Rhino and would appreciate any assistance. Thanks!

Hi Grace - please post a working and non working (the smaller the better) py file, or send to tech@mcneel.com, with a link back here in your comments. Also, please run the SystemInfo command in Rhino and copy/paste the results here.

-Pascal

What was the fix for this issue?

Hello- I do not know if there is one - I am not sure we got an example file - can you upload one or send to tech@mcneel.com with a link back here in your comments?

thanks,

-Pascal