Failed to install Squid (ShapeDiver edition)

Hi everyone,
could anybody help to resolve the problem? I cannot install Squid for ShapeDiver.
The plugin is downloaded and put in the libraries folder, further unlocked, but still doesn’t appear in the grasshopper working window. Tried to install at least the original squid plugin, it didn’t work either.

What is the problem?

Some users have solved this issue by using the GrasshopperDeveloperSettings Rhino command and making sure to check the box Memory Load .GHA assemblies using COFF byte arrays.

We are not quite sure why this step is sometimes needed but it seems to reliably solve the issue. Let me know if that works for you.

Thanks for response, tried it out and Squid appeared in the window, but during the launch of grasshopper there was this window with errors


and after, while opening an example containing Squid (ShapeDiver) components there is this list of absent plugins
4

the button Download and Install works unsuccessfully

Well that looks like a hot mess :sweat_smile:

It seems like you are getting errors for plugins that are not related to ShapeDiver too so I’m not quite sure what the problem is. Do you have the latest version of the ShapeDiver plugin installed? Also try to uninstall the regular version of Squid if you have it installed.

Indeed it is. I did not install the rhino version of Squid. Yes, the ShapeDiver is up to date.

I completely wiped my installation and reproduced the installation steps without any issues. The only thing is that when installing Squid (ShapeDiver edition), you should only copy the ShapeDiverSquid.gha and not the BitmapComponent.gha because it already comes with the ShapeDiver plugin. It seems that the version shipped with Squid is a bit older and could cause conflicts, so double-check that the BitmapComponent you are using is the one from the directory listed in the ShapeDiver.ghlink file. However, I didn’t get any errors even in that case (besides being prompted to pick one of those two files).

If this last step doesn’t solve your problem, maybe post more information about your system (OS and Rhino release candidate version).

1 Like

Thanks Mathieu, I tried reinstalling everything (all the plugins supported by ShapeDiver) and it asked about conflicting files again, so I chose to replace all but it said that there are 40 objects missing (forgot to take the screenshot), and now there is a problem showing with only one plugin (will report later, which exactly. having some deadline issues here). But as for squid, it seems ok for now, no errors.

Hello, for months I had the same problem as you, and when reading this post I was able to solve the problem. I just had to follow the instructions of
‘Mathieu Huard’, but also use the command ‘GrashopperLoadOneByOne’, and now I have Squid (Shape Diver edition) in my grashopper.