ExtrudeSrf - Maintain Source Layer

When using the ExtrudeSrf command in both Solid=Yes & No modes it creates the new object on the Current layer, moving it away from the source layer that the input surface used to be on.

When using the OffsetSrf command in Solid=No mode it creates the new object on the Current layer, moving it away from the source layer that the input surface used to be on.

When using the OffsetSrf command in Solid=Yes mode it does actually create the new object on the input surface’s source layer.

For the way I work, 99% of the time that I run either of these commands I want the results to stay on the source layer. Can we get options to control this behavior? Like how the Make2D command has the “Maintain Source Layers” option.