Extrude Srf in GH - missing options

I have the same issue as in this thread: Extrude surface distortion but in GH.

I am extruding a surface created from some text:

As you can see on the inside of the D there is an error similar to the thread above.

If I bake the surface and extrude in Rhino with normal options I get the same error. If I switch on “Split at Tangents” it works fine.

extrude_srf_rhino

Is there a reason why that option didn’t make it to Grasshopper? I can’t see any good reason why it wouldn’t.

Is there a plugin/script where I can use those options?

extrude_srf.gh (156.5 KB)

Recently, there was a topic about similar problem, which was not a problem with geometry, but rather about the render mesh setting. You could make your geometry with increased resolution or use a custom mesh setting.



extrude_srf_re.gh (161.0 KB)

Hi Kim.

Thanks so much for your answer. Well, I am not sure what exactly causes it, but it also happens in Rhino in the same way. I noticed that rebuilding the curves helps with it, but I still don’t get why the option was omitted for GH, when in Rhino you don’t have to uselessly rebuild any curves and can just use the Tangent option.

Run “ExtractRenderMesh” command in rhino and check the result if you like…

Okay, I tried some things again, and yes, you are (of course) right as always :slight_smile:

ps: I had already marked your answer as solution, but took it away again, as it’s technically not a solution, but a workaround. Having similar options in GH as in Rhino is the solution. Oh and of course improving the meshing algorithm, which is pretty flaky…