Extreme lag when hiding/unhiding/ShowSel etc. with RTX A3000?

No, I mean the ‘boosting’ of the individual cores, not using all of them (which rarely ever happens,) check to see if it’s being throttled. Go to Task Manager, got to the Performance tab, then click at the bottom on “Open Resource Monitor,” there in the CPU tab check the Maximum Frequency. It should be over 100%.

Anyway, laptops are weird and opaque. I wouldn’t think so from BOXX but maybe the memory is not configured right, or it’s been kneecapped by being a single sick of RAM.

Hi, ok thanks.

Yes Maximum Frequency is up to 190%

Okay so the CPU is probably doing okay…it might be that there is something suboptimal with your RAM configuration, or sometimes that stuff is just strangely slow in Rhino. What are your Rhino undo memory usage settings?

It is set to 256 MB, default I think

No, fyi you can run Quadro cards on the Geforce drivers these days. If you mix the card types, you have to (I’ve been running a P4000 and an RTX2080 in the same box since the 2080 came out).

Hi @c.wallgren,

More things to consider:
Do you save your rhino files to the laptop or to a network/server/cloud drive?
Do you run the same antivirus setup on both machines?
Do you have any “bloatware” apps that came with the new machine and are running, perhaps unbeknownst to you in the background?

Do you still have the old laptop? If so I’d suggest copying one of the problematic models back to it (along with any linked files) to see if the problem goes away - just to make sure that the problem does lie in the new machine and not in the file.

Again, thanks for all help, I´m currently contacting BOXX for support.

Will post solution if found.

Ok, I belive we solved this now.

We limited ESET antivirus to not interfere with Rhino program files…

…but also and probably the main reason - turned of virtual memory (page file), I have 32 GB RAM in this computer and rarely see more then 16 GB usage so hopefully it will run fine, have stress tested it with Rhino now for a while without any of the older or new issues.

All the best

Okay, yeah antivirus software is kinda crap.

DON’T turn off virtual memory. Windows needs that to work.

Ok, I really think the page file is the main reason and I´ve been working with it shut of for the last four years without problem, just needed my old support guy to remind me how I had my old laptop setup.

I will stick with these settings now but cant promise they work for everyone.

There’s no evidence turning off the page file speeds anything up, only that you will run out of memory and crash. There are things that specifically require virtual memory, I ran into that with GPU rendering a while back, I had ‘enough’ RAM but was running out of memory because I didn’t have enough specifically virtual memory for caching.

I will report back in a weeks time. :+1:


I have a Lenovo P15 Gen 2, with an A3000. The chip seems to work pretty well for Rhino. Even though the P15 Gen 2 could stand more cooling, it Cycles renders surprisingly well. I fret over the idea that the A3000 might be comparable to my GTX1080 desktop.

I just download drivers for the A3000 laptop this morning. To download them, you have to make sure you are in the RTX laptop dropdown box, as there may be no A3000 desktop card. nVidia’s website user interface could use some work. Though, I think that a few months ago, I had trouble finding A3000 drivers.

Also, please make sure that if you are not voiding your warranty by using non-vender drivers. In some situations, addition thermal management software might be called for.

In the Nvidia settings, there are power management settings for more performance and less lag.
Generally, I feel that you don’t need a lot of anisotropic filtering unless you are applying textures to deep, long things, like hallways and valleys.

In Windows 10, you must also make sure that the GPU is set for Rhino in BOTH the nVidia settings AND the Windows ones.

[I trying to help a friend learn 3D modeling in Blender, which I don’t use much. Though, I’ve been doing some FEM studies in Freecad, because I am running a low-buck operation.]

It’s a choice that I make for myself, but I disable virtual memory on my machines because Windows will issue it stupidly when it’s not necessary–BUT Windows uses the VM (contiguous) area for crash-dumps, so, if you disable VM, and if your computer should crashes, you will have less clues as to why. Also, I have 32GB of memory, which is usually sufficient but not excessive for my Rhino projects.

Thanks Brenda, interesting and good to know that I´m not the only one running without VM.

I think I have my GPU set up right and I really belive my problems are related to RAM access, anyways it seems to be running well now without these “spells”.

From your description above, you made two changes at the same time: removing the pagefile and constraining the antivirus. To be certain the former was the solution (and, cards on the table, I’m sceptical of that, because experiments with other software have shown insignificant differences in performance) you need either to accurately reinstate the antivirus so that removing the pagefile is the only difference, or reinstate the pagefile so that constraining the antivirus is the only change. That way you should end up knowing rather than believing.

As for running without a pagefile, are you aware that you can see how close you have recently come to exhausting available RAM with the Process Explorer tool in the free Sysinternals utility package from Microsoft? here’s an example from the laptop I’m currently using:

This shows that my 16GB of memory and a modest pagefile (managed by Windows) give me a limit of 19GB. My peak usage in my current session was 17GB, so I was just over my physical memory and within 91% of my limit.

If you are going to operate without a pagefile it would be worth running up all the apps you might run concurrently, giving them a good workout for some hours (to ensure you account for any memory leaks), and then running Process Explorer. That way you will be making an evidence-based assessment of the safety margin you have.


Thanks, good input.

Yes thought about testing with one change at the time, sure …haven´t got to that point yet.

Will check with Process Explorer.

and/but …still got the effing lag, works much better now though.

Thats the whole thing really, the intermittence - everthing works great for 40 min and all of the sudden it takes 2 min just to unhide an object, reopening the file seems to fix it now - after changes (did not before).


I don’t know how much tech understanding you have or how deep you want to get into this, but you could buy or borrow a copy of “Troubleshooting with the Windows Sysinternals Tools, 2nd Edition” which includes a section on troubleshooting sluggish performance, then use Process Monitor to drill down into what is happening on your machine at the point it goes slow. This is not a trivial task though…