Expression x-1 or -x or 1-x



Ouch… No text in… Well. This I see in alot of videototurials. Trying to learn. This stops me everytime. I can make it on the component as an expression and well… Same error… Nothing helps… Why is this ?

Hello. It looks like there is a space before the x in the input name or in the expression

No there is not. Believe me. I tried this many times. I dont get this at all.
Its realy bugging me.

Graham is correct:
Right-click over the input parameter “x” and check if there is a space:

Also, take a look here Help Us Help You
It is useful to attach your definition (the .gh file) to get help. And remember to internalize data/geometries, if needed.

1 Like

I have done this many times… No use. Thank you for your reply tho. But this is not the case.

Could you post the part of script that didn’t work?

You can use the “x-1” #pufferfish component! :wink:

I think when you removed the word Variable you kept the space before x
and don’t forget to recompute (F1) after you rename the input to x