Exporting to Sketchup fails

#1

I can’t export to Sketchup for a client. I’ve tried different models and different versions all the way back to 2008 but it returns ‘file writing plug-in failed’

(It works OK in V5)

Andy

1 Like
#2

hello.
I work with Rhino and Sketchup as well.
Can you please tell me your Sketchup and Rhino Versions?

If you have a heavy file to export from Rhino to Sketchup, it will probably crash rhino.
For that, try to export small parts from your rhino model.
If this wont work, try to export in COLLADA extension from Rhino and uncheck merge faces. With this method you will not loose created groups but loose reference point.

I hope it will help you

#3

Hey,

The files are only a few hundred KB single objects but export well from Rhino 5.

I don’t use Sketchup that often, it’s what this client uses to vet models before 3D printing (as well as renders)

Thanks for the pointers, I’ll bear that in mind. It was more a note for the developers, I was able to get round it with V5.

Cheers

Andy

(Tim Hemmelman) #4

Hi Andy,

V5 uses the SDK from Google. V6 uses the SDK from Trimble. Send me a model that doesn’t work and I’ll see if I can pinpoint something in the debugger. If the problem is in their SDK though I won’t be able to tell you anything other than it doesn’t work.

Tim

#5

Hi Tim,

It was just a by the by for you guys in case it was a WIP bug that needed ironing out. It wasn’t much of a problem for me, I sorted it pretty quickly.

It does seem to be any export… I drew a box just now to test it again:

Work In Progress
(6.0.16199.22351, 17/07/2016)

Andy

1 Like
(Tim Hemmelman) #6

Hi Andy,

Thanks for reporting this. It was a bug in the plugin. The plugin uses Rhino’s Earth anchor point to set the geo reference in the SketchUp model. I suspect that at some point the defaults for that went from 0.0 for lat, long, and elevation to the value of an unset double. The SketchUp SDK didn’t like the latter so it was returning an error result and the plugin bailed early. I added code to check to see if the Earth anchor point is actually set before attempting to use it.

http://mcneel.myjetbrains.com/youtrack/issue/RH-34975

Tim

1 Like
(Kelvin Cheng) #7

@2DCube

The next release of Rhino WIP will have this fix. Thanks.

1 Like
#8

Tim,

I’m curious why some objects won’t export as skp. Here’s one in particular. Each face test as planar. It’s closed with edge tolerances below the file tolerance.
Failing SKP Export.3dm (3.9 MB)

Out of curiousity I found this particular face which cannot export. Doesn’t seem to be too unusual.
Single Face.3dm (106.4 KB)

Geometry:
Valid polysurface.
Closed solid polysurface with 915 surfaces.
Edge Tally:
2268 manifold edges
Edge Tolerances: 0" to 0 5/8"
median = 0" average = 0"
Vertex Tolerances: 0" to 0 5/8"
median = 0" average = 0"

(Brian Gillespie) #9

@tim did you see this?

(Tim Hemmelman) #10

Hi Alexander,

Thanks for reporting this and especially for including the models, they were very helpful… Sorry I didn’t see your post until Brian brought it to my attention.

This should be fixed in the next public wip. Here’s the YouTrack issue so you can monitor the progress if you’d like. http://mcneel.myjetbrains.com/youtrack/issue/RH-35503

If you see stuff like this in the future be sure to send it in (konk me on the head if I don’t notice) and here again, having the model (the simpler, the better) is really, really helpful.

Cheers,
Tim

1 Like
#11

I’ve updated my WIP and still cannot get the object to export even though the face I submitted before works now. Here’s another face I’ve identified… I think I built this object using weird tolerances?

(Brian Gillespie) #12

Hi Alexander,

We generally release public WIP builds every Tuesday. You won’t see an improvement until next week.

#13

righto. thanks.

#14

If it’s only that face and the building is mirrored you could split the model in half, mirror it, join and then use the command _MergeAllFaces as a stop gap measure.

#15

true. I fussed with it a while and got it to export. deleting random faces and then capping…

(Kevin An Mi) #17

Hey guys, resurrecting a two year old thread…

I’ve still been having this issue and I’m running the most up to date stable rhino 6 build.

I’ve had a few instances of going from sketchup to rhino and back to sketchup and that’s where things go haywire. I’ve found two workarounds:
a) copy into new file and reset earthanchorpoint (thanks @tim for that suggestion)
b) saving it down to rhino 5 and exporting it from there

I am hoping there is more information about why this is happening and how to make it stop happening?

Thanks!

1 Like
(Tim Hemmelman) #18

What doesn’t work for you?

I can tell you this. There’s something about the Trimble SketchUp SDK, what we use in V6, where it doesn’t like triangles that have very short edges. I looked at the code and we warn user’s when there are edges shorter than .002 inches (that’s an arbitrary number but it seemed to work in most test cases). When you have triangles with edges shorter than that they don’t appear as triangles in SU, just lines where the edges would be. I don’t think the Google SDK, what we used in V5, had that issue. This only applies to the actual geometry. What I mean is, if you’re having trouble, you can scale an object very large make an instance out of it and then scale the instance back to the original size. That’s another way to get around the problem.

More details about exactly what’s not working will help us try to understand what’s possibly going on.

Tim

(Kevin An Mi) #19

Hi Tim!

Thanks for the speedy response on such an old thread!

Based on what you said, it might be the root of the issue. I am using Rhino to build topography via the patch tool so I can export to sketchup for the rest of the project team. And sketchup is for sure triangulating the heck out of the surface the patch creates. I’m not positive any of them are smaller than .002 inches, but given that there are thousands of triangles, I’m sure at least one gets that small.

It is interesting to me that the SDK is has that issue now!

Thanks again for the quick reply.

Kevin

(Jonathanm) #20

I am also experiencing this issue, and even when trying to export just a plane. Sometimes it works, but occassionally I get this bug and can’t fix it. Export to Sketchup Fail.3dm (7.3 MB)

(Jonathanm) #21

I have copied the problem piece into a new scene and exported a generic plane first as a skp file, which worked. Then I tried with the problem piece and finally got this message reporting there may be 1 mesh edge that is too short to be valid.
image