Exporting model oriented to keyshot

I am trying to export my model made in Rhino to keyshot. Unfortunately rhino can not export ‘locators/gumball’ orientation. They said to me in the forum of KS that If i convert the model to a block, then I can export the right location of my model. Did not work either.

The funny thing is that they showed to me …and it seems to work. I am doing exactly what they told me. Converting to block…but nope…my object in Keyshot has a pivot totally different from the model orientation.

I would like to ask if anyone of you manage to export a model from rhino to KS or other software with certain orientation ?
Thanks a lot

Works all the time. And you should not need a block either.

When you say “orientation” do you mean it is 90 degrees off? If so, play with the ‘Up’ axis on import, i.e., change it from Y to Z.

Does that work?

I mean . I Import the model to KS. In keyshot the pivot…its totally un-aligned in respect with my model.
I can send you the link to the topic in KS forum .

You import with these setting?

Is everything in the right location?

After import, do you then need to rotate (“pivot”) specific objects, specific degrees, or entire model? If so, while this can be done (successfully or unsuccessfully, depending…) under certain circumstance, easier to orient as desired in Rhino, then import as above. Unless you are trying to animate?

As you can see the model is not aligned with the pivot. Even if in rhino the model was created from the scratch with that inclination. In rhino the isocurves are correct and aligned with the tilting.

Hmm, if you can post the .3dm I’ll take a quick look. I see you are KS 7.1. Still v6 here. I’d be curious is 6 does the same, etc.

Yes sure. Thanks!

help_Rotation.3dm (51.3 KB)

I have been in contact with a KS developer. Apparently the only way to freeze the model with the right orientation is to convert it to a block…Which for me is quite painful.
Basically you re model the ‘tilted’ shape aligned with the world axis…then you convert to a block…and then you need to re orient it again…

1 Like

I see now. It appears to be coming into KS with axis alignment same as in Rhino? That might be expected, albeit annoying, behavior???

Perhaps you will need to remap or take the block workout.

So far…according to KS developers…the only way is ‘blocking’

1 Like