Export selected dxf not working

Hi, I don’t have much time to post in detail right now but I’ve tried “export selected” to dxf in Rhino Beta and it does nothing.

Ok. After I clicked to open the “options” when trying to export to dxf and immediately closing, it does work now. Strange.

But when I press cancel in this window:

I get this error:

Can you ensure the acad export plug-in is loaded? If not, try loading manually, then see if exporting works better?


Right, I am guessing here that the plug-in for some reason didn’t properly load when you selected dxf as the export format. I have seen it a few times before, but haven’t been able to repeat.

I see the fail dialog on cancel as well. I have reported it as RH-42548

RH-42548 should be fixed in the latest BETA.

I’m having the same problem again here (not the fail dialog): I couldn’t export to dxf with export selected in the last Beta. Opening the options helped again. But I’ve had the problem earlier today and then opening the options didn’t help so there was no way to export to dxf except for copying everything to V5 and exporting from there.

Hello - does the save location matter (i.e. drop-box folder vs network folder vs. local drive?) ? Is there any feedback at all on the command line at all when the command completes?


Hi, Good question! I only tried saving to dropbox when it wasn’t working. It didn’t give any feedback after the pop-up window.

Ok. I just tried making a new file and recreate this but everything was working normal. Then I reopened the file and tried exporting from that file and that gave no issue either. But then I tried going over the steps I was doing before and now it seems to do it again! I’ll do some more testing and try to find out on which of the steps I do is causing this.

I think our guess of the moment is that saving problems in drop-box folders may be related to collisions in timing the backup/synching and Rhino’s saving process.

Right. Here’s a few things I’ve been trying out. It seems like it is related to dropbox but I cannot find out what exactly is causing it:

So saving to a folder in dropbox as “test” doesn’t work.
I try saving to my desktop - It gives me the dxf options window meaning it Works
I cancel actually exporting
I try exporting again to dropbox - still doesn’t work
I try exporting to a subfolder in dropbox - doesn’t work
I try exporting to a parent folder in dropbox - it gives me the dxf options window meaning it Works
I cancel the exporting by pressing ESC
I try exporting to the exact same folder as where I just got the dxf options window - it doesn’t work???
I try exporting to a folder on my computer - It gives me the dxf options window meaning it Works
I checked, I still have over 50% space on my dropbox folder.
I try exporting to a folder on my computer and moving it to dropbox - In both cases it Works
I try exporting to dropbox again - doesn’t work
I try the same dropbox folder chosing a different name - doesn’t work
I try selecting something else from my file for exporting to dxf in dropbox - doesn’t work
I try exporting to a different folder in dropbox which I haven’t tried saving to - it Works!
I cancel and try exporting to the same folder - it doesn’t work
I try another folder I haven’t tried - it works
I don’t cancel and try exporting again with a different name “test2” - it works!
I now cancel again and try exporting again with “test2” - it works
I cancel again and select something else in my file and try exporting with “test2” - it doesn’t work
I delete “test” from the folder and try exporting as “test” again - it doesn’t work

Hello - I see. I guess the real test would be to suspend or stop drop-box’s syncing and see if all of this goes away.