Export Downloads - Issues with some File Types


After reading the available documentation, I tried to deploy my first attempt at model exporting.

However, for some file types, Export Downloads are not working properly.

In my case, STL and PNG are not responding, G-Code and 3DM download files with empty content, and only DWG (out of the 5 file types I have tried so far), works flawlessly (which is fantastic btw!).

FYI, I used the Dynamic Javascript Interface from Dynamic UI Tutotial.

The deployed interface is here.

Attached is my GH file and the Hi-Res pic of the definition.

Any light on this issue is greatly appreciated :slight_smile:

Best regards,


Engraved-Boxes_DEV-0.0.3.gh (35.2 KB)

The ShapeDiver export components support many file formats, but not all of them are compatible with all the data types available in Grasshopper. It is the responsibility of the definition to make sure the geometry sent to an export component makes sense with respect to the chosen file format.

In your definition, you are trying to export a Brep object, which is compatible with DWG and 3DM out of your list. For the other file types, it’s pretty clear why they’re not working:

  • PNG is compatible with Bitmap objects only. Check out the documentation to learn how to import, internalize and use Bitmap objects in your definitions.
  • STL is compatible with meshes only. I’ll check whether Breps should be converted automatically to meshes before exporting, but it wouldn’t make sense anyways because you typically want fine control over meshes in STL files used for 3d printing.
  • G-Code is a plain text file format, the export component does not generate G-Code itself. This needs to be done in the definition, and the resulting text needs to be used for the export. The extension is supported as a shortcut, so that users don’t have to rename text files after exporting them from ShapeDiver.

I tested the 3DM export in your deployed interface and it seems to work fine, can you describe the problem you’re having?

Hi Mathieu,

Thank you for your reply. I makes total sense.

Regarding the 3DM, if I recall correctly, it was opening up “empty”. I am gonna try to reproduce the issue again.

On another note, since you replied (and I made the necessary small adjustments) I have been trying to upload an updated version of this definition, but I keep getting upload errors. Below are the reference codes for the upload errors:

Ref: 476aea1f-50b9-4867-a16d-10a690135f3b
Ref: 31902a5a-b486-498f-a903-45725d801174

Is there a way for me to check what the upload problem is?

Thank you in advance,

Andre Philippi