Explode command seems slower in SR11

Anyone else notice this? I’ve done a side by side comparison with SR10 and SR11 and there is a noticeable lag in the latest release. I am exploding nested blocks, so maybe that’s where the issue is?

I’ve noticed the Python ExplodeBlockInstance method has also taken a turn for the worst. It also hangs. I have cases where it was pretty much instantaneous in SR10, but hangs for close to a minute in SR11.


Can you send the files that show this to tech please? http://www.rhino3d.com/upload


Thanks! I’ll respond through tech as well and will file this now. I see a 6 second wait in SR 11 on the fourth Explode while SR 10 does the fourth in about a second like the first three.

Here is a script you can run on this test case that will show the deteriorated performance of the Python method

import rhinoscriptsyntax as rs

def ExplodeWithName(block):
    name = rs.BlockInstanceName(block)
    objects = rs.ExplodeBlockInstance(block)
    if objects:
        for object in objects:
            if not rs.IsBlockInstance(object):
                rs.ObjectName(object, name)
    return True

def ExplodeNestedBlocks():
    blockObjects = rs.ObjectsByType(4096, True)
    if blockObjects == []:
        print "There are no block instances to explode. Command terminated."
        print "Blocks and nested blocks are being exploded. Please wait..."

    if blockObjects:
        for block in blockObjects:
        print "All block instances have been exploded down to their native objects"

if __name__ == "__main__":

It looks like the copy and paste messed up the indent under “if blockObjects:”.

Dan, I messed around a little with this and did not see any noticeable delays in Sr11 vs Sr10… Brian J did, however. Not sure what the difference is- what sort of lag, approximatelty, are you seeing - that is, how long does it take for the script to complete with the file you sent us?



Hi Pascal,

I’m seeing a 7 second hang when running this on SR11. On SR10 there isn’t more than 1 second.

7 seconds might not seem worth worrying about, but run this on a model with 100’s of blocks and you might as well go for a coffee break.


OK, thanks - I had about 3-4 seconds on both SR10 and 11. I’ll test some more.


I have another file that the method will fail on in SR11, but works on SR10. It’s about 12Mb zipped if anyone is interested in seeing it. The traceback tells me this:

Message: 00000000-0000-0000-0000-000000000000 does not exist in ObjectTable

If it hadn’t been working fine up until now I would assume it’s just my poor programmings skills. But it’s worked like a champ up until this SR.

Pascal, can I send this to your e-mail address?



Hi Dan - I got your file, thanks. I’m taking a look.


Hi @BrianJ
Since you noticed a delay similar to what I’m seeing, I’m curious as to whether you have the Autodesk Shape Modeling plug-in installed? Since @pascal didn’t experience the delay, I’m wondering if perhaps he doesn’t have this plug-in installed.

I think I may have discovered a connection between the delay and the presence of this plug-in, but since I’m the only one here out of 120 Rhino users that have it, I can’t confirm that. What I can confirm is that if I disable the plug-in at start up, the delay is gone.



I don’t and haven’t had it installed before. I do have a lot of plugins though for testing and helping users… it very well may be a factor so I just tried launching Rhino 5 x64 SR11 in safe mode and the delay in the fourth explode is roughly a second not 6 or 7. So I think you’re on to something but the question is now which plugin is involved. I’ll have to go one by one later and see if I can figure it out… thanks for letting me know what you found.