(Exoskeleton 2): Cytoskeleton Not Loading

Rhino 6.
I have Plankton v0.4.2 from Releases · meshmash/Plankton · GitHub (I also tried Plankton v0.3.0). Using Exoskeleton2_150904.zip. All of these were plopped into Grasshopper/6/Libraries.

On launching Grasshopper, I get the following error messages:

Object: Cytoskeleton (level 1)
{
_ Exception has been thrown by the target of an invocation._
_ TargetInvocationException_
}

Object: Cytoskeleton (level 2)
{
_ Could not load file or assembly ‘PlanktonGh, Version=0.3.0.0, Culture=neutral, PublicKeyToken=null’ or one of its dependencies. The system cannot find the file specified._
_ FileNotFoundException_
}

When Grasshopper loads, Cytoskeleton is missing.

Missing

Does anyone have a fix? I’ve seen the problem posted (mostly 4 years ago), but I can’t find the solution.

1 Like

I have the exact same problem. Anbody have a solution?

1 Like

I am new to grasshopper and I am having the exact same issue… Has a solution been reached?

It seems that you are missing PlanktonGh.dll. I don’t know which distribution it belongs to, so I apologize to the author for putting it here without his consent.
Exoskeleton2_150904.zip (55.0 KB)

1 Like

That’s weird! I have the latest version installed. Do you think one of these plugins is conflicting with it?

Screenshot 2021-03-11 123255

Hi @leumas1311 - which version of Rhino are you using?

In 7 you can use MultiPipe to do the same thing.
(Cytoskeleton was one of my first attempts at this kind of tool many years ago)

1 Like

So I was having the issue with Rhino 6 and then yes, I did see that you can accomplish the same thing with Multi pipe in 7 so I upgraded and have been experimenting with that. I first posted on here before learning about Multi pipe. I wonder if there is some sort of internal conflict since the cytoskeleton and multi pipe do such similar things… The issue is basically resolved at this point.