Exception was thrown with element parameters

Hi,

I’m currently working on a bridge project, to do so I created Revit family, with the different component needed built in that i parametize with GH. There was some little corrections needed in one of the family in the model. When I imported the corrected family in the model, everything seemed to work fine…But when I reloaded my GH script, I got multiple error for the element parameters concerning that object.
Photo pre-correction:

Photo post-correction:
post correction

Photo post-GH:

Here is the error message:
image

When I manually create the same object, there is no problem in Revit, which lead me to believe it’s a GH problem.
I tried reloading, rebooting and re writting the script but nothing worked.
I can give you the files if needed.

Kind regards,
Colin Maes.

We’ll need more information to be able to help, thanks.

Hi japhy, Here is a wetransfer link, in it you will find a revit model with the latest family i created. There is also all the Gh definition, but the one with the problem is called “Aile”. i also joined the excel and gh data and the revit families in case. Everything should be internalized in the definitions.

To recap, the last version of “BEG-GOV-Profile-Aile” work when imported in the revit model, but once i reload the GH definition “Aile” it doesn’t work anymore.

Do you have a smaller example showing the workflow issue? This is going to be hard to replicate with the files provided. Thanks

Sure i understand, sorry for the trouble, here is a much lighter version, there are 2 beam linked in Ghrasshopper, and copy of those beam made manually.

Here is a link: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

I hope this will do!

1 Like

Ok, I got it going, now how do i break it?

Hi Japhy,
Sorry for my late response i was away from work.
I have a licensing problem at the moment, but i wall look in to it as soon as i can. I Believe it should be breaking by it self, which doesn’t seemes to be your case…
I’ll come back to you!


Hi Japhy, so i checked the file i sent and it shouldn’t be working as the picture shows…
Any idea why it works on your computer but no mine?
Just in case here is a new link with the files… Maybe i sent it wrong to you…

I hope it doesn’t work this time i guess?
Thanks for keeping an interest in this topic.
Have a good day.
Colin