Excel Table in Layout

This doesn’t seem to solve the problem :frowning:

Hi @milezee @Macuso @wim @carvecream @djordje ,
Here is a new version that let you insert tables from a .xslx file.
This is a limited version, without editing features but it works fine for those who had issues with csv.
Best regards


(The command is TableV2Beta )

Thank you for the new version. Still not working as expected in Rhino6.

TableV2Beta_Rhino6_test.zip (4.3 KB)

@Matthieu_from_NAVINN yes still doesn’t work, using V6 here :neutral_face:

My bad, it did not read numeric cells and I tested it with a text-only table so I couln’t see it.
This version is fixed, only for Rhino6:
Let me know if its works.

Thank you. Now it is working much better. It is possible to make also a Rhino5 build for compatibility reasons? Still are plugins and Grasshopper componenents that I need to use and which unfortunately they are not working with Rhino6.

This one works for both v5 and v6:

1 Like

Yes, now it is also works in Rhino5. Thank you.

can’t get this to load in V6, have tried to uninstall, now getting this error message every time I open rhino model, screenshot attached :frowning:, how do I get rid of this please ? It doesn’t show up in the PlugInmanager.

@dale, @brian, any idea why a basic plugin would refuse to load on one computer and would work for others?
And how could it could be missing in PluginManager?

it loaded and worked in V5, not in V6 eval, I get this pop up every time I open V6 now, any ideas how to get rid of it and try and reload the plugin ?

To uninstall a plugin manually you have to delete its directory, then restart rhino. In our case it should be something like:
C:\Users"USERNAME"\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\TableV2 (061e8a18-8922-4965-bf3c-a222207e40de)\


I am able to drag & drop the appropriate .rhp file on to their supported Rhinos. Perhaps having a separate .rhi file, one for each version, is a better approach?

– Dale

@Matthieu_from_NAVINN @dale updated V6 today, now getting this error ? screenshot attached :frowning:

We can try that, but I thought rhino plugin installer was supposed to manage multiple versions automatically?

Hi @milezee, I’m pretty sure this screen capture was taken from Rhino 5. (You have the tab “new in V5” and your rhinocommon version is 5.1).
Installing rhino6 does not remove rhino5, so you might have used the wrong shortcut.

Anyway, if you still have issues, could you try this:
Unzip the .rhi file for table plugin. Inside you will find two .rhp files, one is for rhino5 and the other for rhino6. You can just drag and drop the one needed in the appropriate rhino windows

Did you get this by dropping the .rhp file onto Rhino 5?

It is. I tried your latest .rhi package and it registered the correct .rhp for Rhino 5 and Rhino 6.

If anyone experiences any issues after installing the combined .rhi, can you please let me know the error and send me your logs? You’ll find them in %appdata%\McNeel\Rhinoceros\6.0\logs (replace 6.0 with 7.0 if you have the WIP installed).

@will I get that error message every time i open rhino V6 now, its soooo annoying, I’ve deleted it from the plugins folder too :frowning: , any ideas how to get rid of it ? I did another thread here in desperation, tia

@will @Matthieu_from_NAVINN i think i’ve solved it, for some reason the plugin was trying to install as V5 in V6 if that makes sense, I’m confused too but for now that annoying pop up happens no more and the Table plugin seems to work ok :slight_smile:
It seems to import the table as a block, is there a way to just import the table as 2 groups of objects, one would be the outline of the table, the other would be the text as a seperate group of objects ?