Excel is not publishing from Gh

I have been able to use this component successfully before, but this time I am getting this error message. I am working on a different computer and with a commercial version of Rhino7.
Here is the error.

  1. Solution exception:Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

Gh to Excel.gh (5.2 KB)
This is using the latest TTToolbox plugin. I got the same error message using the latest version of Bumblebee.
Its probably something that I am doing wrong.
Any help would be appreciated. :sweat_smile:

Update. I have the same problem using GhExcel. :confused: Same error message to.

Nor Lunchbox. No error code on this one though.

Your path seem strange. most of the type xls file have an extension.
And what is the name of the sheet. Depending on your Excel version the sheet1 could be named Feuil1 in French and surely other name.

Write to the plugin maker.

Thanks for looking at this for me Luarent!
If you don’t mind explaining a little more on what you mean by path, I am having a hard time understanding.
My sheet name is Sheet1.

Ok, I will do that.

Thank you for looking at this for me! Much appreciated.

Path is the directory and file name. File name like myexcel.xlsx. Also I am not sure double quote aee allowed in filename.

your file name needs to look like this:
C:\Users\User\OneDrive\Book 3.xlsx
or this (in case of problems with spaces in the file name)
“C:\Users\User\OneDrive\Book 3.xlsx”

Ahh Gotcha. Thanks! I will try that.

I put in the now correct file path. Unfortunately it did not work. But that does get me closer.

Check if worksheet as a default name

Just double checked. It is a default sheet name.

I stll wonder if your path is well written
No double quoutr

I took out the double quotes. That also seemed to work like you said. As in its the correct file path.
I also switched back to the TT Toolbox plugin.
Could you try recreating the problem with the file that I attached in my first post?

it worked as expected here…
created the file, added the values.

if the file name doesn’t exist, it creates a file though without saving it on the indicated place. if the file exists, it opens it and adds the values. I cannot reproduce your error here.

So maybe it has something to do with Onedrive or Excel. :confused:

I tried the solution mentioned in this thread. Still no luck

So it looks like it may have something to do with the files not being able to open in the desktop version of excel. The files will only open online. Not sure where to take it from here.

@laurent_delrieu @benedict
Thank you for looking at that for me. Much appreciated. :slightly_smiling_face:

1 Like