Eval won't open

Hi, I have downloaded the evaluation version as well and i have the same problem.When i click the app nothing happens. I have tried everything such as display adapters, safe mode etc. Is there any solution to this ?

You replied to a 3-year old message from a different version of Rhino.
I moved this to a new thread so it will be seen.
Please do not reply to old message threads even if they seem related.

In Windows Device Manager > Display adapters, do you have a “Citrix” adapter?

Sorry for that John. Yes I have the citrix adapter

That is what is blocking Rhino.
If you don’t need it, uninstall it.

If you do need it, here’s what we know:
The culprit is epclient64.dll included with Citrix ICA Client, a remote desktop tool.
We have heard you can make apps work with this if you do not enable the keylogger and screenshot feature.

Any luck?

Unfortunately, rhino still does not open. I did delete the citrix adapter but still unable to open. Is there an other way ?

John here is a new problem I could open the rhino program after i entered my email and license key i closed the application. Then tried to open it again but now again i am unable to open it

Since it is a system DLL you must restart Windows after uninstalling the Citrix tool.

Still does not open John

I deleted it and restarted the computer. I tried this multiple times

Hi John is there any other way I could solve this problem ? It’s quite urgent and I’m sure you can help me :slight_smile:

I’m not sure deleting is the way to do this, if it can be uninstalled.


1 Like

Hi Pascal, I tried that as well. Tried it atleast 15-20 times. It just does not want to open

As you said i uninstalled it. and only the other two adapters show up.

Hey Guys is there any way i could get through this ? It’s really urgent as my assignment submissions are nearing.


I am trying to open rhino 7 since the last two days. I have tried re-installing the software multiple times. Yesterday randomly rhino opened and i closed the app to open my other file of rhino and now it again does not open. It happened again today while launching rhino in safe mode after i closed the tab, now it does not respond. I deleted the citrix display adapter and unable to find a solution. Could anyone please help me ? Is there something wrong with my plug-ins?

Hi - are you always opening Rhino by trying to open a specific file are do you launch Rhino from an icon on the desktop? When you get Rhino to run as you have a few times now, please run the Rhino SystemInfo command and copy-paste the result here.

Also, can you provide more information about what “not responding” means?
Does anything happen at all? Is there a “Rhino 7” process in the Windows Task Manager?

So what I mean by not responding is that nothing happens at all. After I click the application it loads for 2 seconds after which nothing happens.
Yes there is a rhino 7 process in the task manager.


Hm… does Alt-Tab show you anything -like maybe an error or message box that is waiting for attention?


No Pascal nothing working on my background. And no error message pops up as well.