Error writing to file: Verify that you have access to that directory

Hello, I have been trying to reinstall Rhino 7 on my laptop. I had installed it yesterday, had the shortcut in my desktop, and actually used it for a few hours yesterday. But, I checked again today to do some work and it was gone. Can’t find the shortcut anymore, just the installer. I uninstalled and tried to reinstall but this error pops up when I do. I would like some help figuring it out. Thanks!

Hello - try running the installer as Administrator. (Right click > Run as Administrator)

-Pascal

image
Is it here? I tried this and got the same error

Hello - I do not know, I’ll see what I can find out - are you logged in as the same user as previously? Have you rebooted the machine? Installing does need Admin privileges, but it seems you have tried that.
Does Rhino show up in the program list from the previous iintallation? For example, in the Windows Start menu - if you type “Rhino”, does anything show up that looks like it will run the program?

-Pascal

No I don’t have anything that works other than the installer, I think

Nevermind, I got it working now!