Error when uploading 'no file'


I am getting the following error when uploading my GH file to SD:
> ✘ The upload failed: An error happened while uploading the file (no file)

The file is 49,7mb.

Any idea why this would not work?

My best


The file size limitations are described in the documentation. The limit is 10mb for free accounts and 20mb for Pro accounts.

I am assuming there is a lot of internalized geometry in your definition. Is there a way to shrink meshes or other primitives that are internalized? As long as you are using them for visualization, you should be able to work with much lighter objects.

In case you really need to raise that limit, please be in touch with us so we can discuss your options.

Hi Mathieu and thanks for your quick answer!
Ezequiel always told me you guys were on it but I hadn’t experienced it first hand yet!

There is indeed a lot of geometries being uploaded. However at this point, we do not require displaying the geometries on the viewer. We have had to create our own viewer on top for reasons I’m happy to explain (mostly involving AR).
The way we are using ShapeDiver in this project is to be able to output CNC milling cutting files from the website.

So at this current point, we need to upload all the static geometries to SD (and reducing file size will probably not get us close to the 20mb limit of our Pro account)

I would love to hear what are our options at this point :blush: