Error - Solution Exception: An item with the same key has already been added

Hi all,

Hope you’re all doing well, this is my first post on this forum! I’m having trouble with the Heteroptera plugin and its “Network from Lines” component. The first time I used it, it worked perfectly fine - I’m using it to generate network information from Voronoi created cells and analyzing line connections post using the Sandbox plugin tools. However, after using it once, trying to use it for different data trees I get the readout error of “Solution Exception: An item with the same key has already been added”. This error does not clear after deleting the component, removing/adding it, or copying it to a new sheet.

Does anyone have any ideas on how this can be overcome? I tried clearing and recomputing the grasshopper files with no luck.

Thank you!

I got a similar error with Network from Lines, it was a while ago
the problem was a tiny curve in the list of lines that was indeed not a line

I created my lines from linear segments so there shouldn’t be any curves hiding in there. I think this has to do with the data not clearing or whatever is going on behind the scenes with the component. When I try to use the “Network from Lines” component now in brand new projects it reads out the same error, even if I copy and paste the same project it worked for before. And when I changed the input to the “Network from Lines” command it also read out the error.

It was extremely helpful when it worked the one time (though now I’m questioning whether it really worked) and exactly what I need for my structure analysis so if anyone has insight on this issue it would really help me out!

This is fixed! Coincidentally it seems Heteroptera released a new version after several years just the other week. I am no longer having this issue with the new version.

1 Like