Error message and analyse failed on Galapagos

galapagos
grasshopper
unhandled

(Clementeremy) #1

Hi Everyone,

I am learning the Galapagos bases. I tried to minimize the length of a curve planned on a wavy surface changing the coordinate of the interpolate points.

But when i run Galapagos, i receive an error message in my code and all the slider goes to zéro.

It results no genomes.

Can someone knows why?

Thank you,

Rémy

galapagos_210318.gh (15.0 KB)


(qythium) #2

Hi Rémy,

I tried your file and it worked the first time round, and even better after increasing the number of decimal places (original was producing too large step sizes)

However I noticed from the screenshots that you were running it on a Mac, and there I got the exact same error as you, but changing from a gene pool to regular sliders got it working:

It looks like there is a bug with Gene Pools on the Mac where the sliders can only take on extreme values… very strange


(Clementeremy) #3

Hi @qythium,

Thank you for your answer. Yes, it might be a bugg on the MAC version.
Does the fact to increase the number of decimal places affect Galapagos? Is it better to have 3 numbers after the coma than 2?

Best,

Rémy