Environmental editor extremely slow in latest WiP

Adjusting environment intensity in Rh 6 is 10x faster than in WiP.
It freezes Rhino and oveheats my machine.
What have you done guys to make it so slow?

I assume you’re using Rhino Render as current renderer? Mac or Windows?

Win version on MBP (bootcamp).
The editor is very slow even if I try to adjust it in shaded view. No such problems in V6.

Rhino Render in the WIP is now the Cycles engine, and with that the environment and material previews are rendered by it. Cycles itself is using only one thread while rendering them, but the update of the screen is done by Rhino in a multithreaded way. I’ll be making some adjustments to how much is rendered and shown at which times which should alleviate that somewhat. Further enhancements in the coming weeks should also help. For now you could select Legacy Rhino Render and when you want to crank out a production render you could then switch to Rhino Render through the top menu.

Further for now you can drop the amount of samples used to render the previews. The default is 150. In Tools > Options > Advanced search for PreviewSamples and set it to say 10 or 15.