Environment rotating but not in NEON raytraced viewport?


#1

I guess this has been answered somewhere but why or how can I rotate the environment. When I change azimut to 180 it rotates in Rhino rendered viewport but not in Neon raytrace mode


(Brian James) #2

Rotating the Azimuth of an equirectangular texture in an environment works here using either Brazil or Rhino Render as the active renderer. Are you maybe using another render plugin? Neon uses (to the best of it’s ability) the active renderer.


#3

I have the Rhino render as render engine. But in Neon traced view it does not rotate. Only in the Rendered view


(Brian James) #4

Strange, I can’t reproduce that error here. Can you upload a file and embed/save the textures used in the 3dm?


#5

Sure. Here is the scene. Eh… How do I embed the textures?P
Neon atimuth problem 00.3dm (562.9 KB)


(Brian James) #6

Your Mapping was set to Environment map for the texture rather than the default of Mapping channel 1. So it looks like Neon doesn’t work fully with that mapping style. Switch it back to Mapping channel 1 and you’ll get the control you expected.

You can embed textures in a 3dm by clicking “save textures” in the save as dialog or by checking the option in Options>Document Properties>Rendering and saving the file again.


#7

Interesting. I must say I don’t understand much about the mapping settings. There are are just to many settings all together when it comes to rendering. And since I was using a spherical map I thought it should be mapped as an environment