Endpoint snapping issues in R8 mac beta anyone?

Did something change in snapping UI that I missed? I’ve been stuck not be able to snap to endpoints and points when drawing lines / polylines. I think I must be missing some setting somewhere bc expect this would otherwise be reported already if more people were having this issue.

I’m on Mac and also having snapping issues - but not the one you’re having. My snaps work correctly, but when I click to snap the first mouse click doesn’t do anything - I have to click twice to start each command.

I have the same issues from times to times. I “just” relaunch Rhino when it happens.
Rhino 8 is pretty unusable for Pro uses on Macs.

@scorr1988 and @o.merrick
Thanks for reporting, can you run _SystemInfo in Rhino 8 and send back the results?

Can provide more info on when this happens or models that show the behavior?

r8betasysinfo.txt (4.5 KB)

Thank you for response. please see attached _systeminfo. when drawing polylines, lines, or moving lines, I have not been able to get endpoint, point snapping to work. i’ve tried different objects - lines. have not detected a pattern. i have seen it on prior builds but kept upgrading, and then stopped using r8 for a time. i’ve tried closing r8, and r7 (sometimes have both open), and restarting r8, and only running r8, but still have snapping issues.
nosnapupload.3dm (44.8 KB)

Do you have Curves turned off in filters, by any chance?

curves are checked - i don’t use ‘selection filters’ tho, so i was wondering if something changed there, or a setting is on that shouldn’t - they are all checked. i’ve also tried disabling that and nothing different happens.

If you have no customizations made to your setup, I would want to try _Reset to factory defaults to see if that helps. (pls save settings for support in that dialog). And before running _Reset - if you have customizations - for now also run OptionsExport

this was a false alarm

Just digging to see if there is anything else: There is a setting in modeling aids “only snap to selected objects”. Can you check?

i think that is it! this was the settings in modeling aids - when i uncheck only snap to selected object, snapping works as i expect. i really don’t think i ever changed this setting - i don’t typically modify settings under ‘modeling aids’. was this “only snap to selected objects” something that could have changed its default in more recent builds?

no, this setting has been there in Rhino 7 too. tbh, I just learned about it today, after using Rhino for 24 years. It wasn’t on here obviously, but it is not something that has been turned on in the defaults. Let’s hope it’s a fluke.