Endless loop - WTH?

I can’t do anything while this is going on, it doesn’t let me go anywhere else on the site…


This is what the main page on the site does here right now…

Hi Mitch-

Have you tried this from a different browser? Same behavior?

@brian might want to take a look here as well.

This was (and still is) Chrome. The only other browser I have on this machine is Edge, that doesn’t do it. It worked fine the last time I ran this machine. I also restarted the machine, no change.

Does the same thing happen in an Incognito Window in Chrome?

No, it doesn’t. Seems to be OK there, but the pages seem to load more slowly (compared to other sites).

Incognito pages don’t use the cache, hence slower. But as they work it looks like corrupt cached pages may be the problem. If so, clearing the cache will fix it.

There was a major dns outage on part of the internet: that might be the cause.

Clearing page cache didn’t help…

I’m not on my home network now, traveling and connecting through my phone, but will try again when I get home.

Do you have any Chrome extensions loaded?

You might also want to right-click the page while it’s in the loop and select “Inspect” and take a screencapture of what the Console is reporting. That might help us pin-point the issue.

Hopefully, needless to say, I don’t see this behavior when I navigate to:
but - if this were a regional proxy issue - I might not.

Back on my home network - no change. Here’s the video screen cap:

Here is another endless loop: https://docs.mcneel.com/undocumented_command.htm
I have tested the loop with 3 browsers: Chrome, Firefox, and Brave.

Yes, I can confirm this using Firefox. Why have you guys so many Javascripts running in the background? *bloat*

1 Like

@Helvetosaur it looks like there’s a logout redirect in the middle there. Can you please go to the Application tab under >>, and clear the cookies for rhino3d.com and accounts.rhino3d.com?

I think after doing that the page should load and work normally.

Yeah, that one is poorly written javascript that was supposed to get users back to the “home” page for help when nothing else worked. But I don’t think the ultimate landing page works anymore.

I don’t know what >> is in Chrome… I only see the 3 vertical dots, which leads to Settings>Cookies and other Site Data>See all cookies, then I found both accounts.rhino3d.com and rhino3d.com in the list and trashed the cookies. Didn’t help.

The >> is next to the rest of the tabs you clicked through in the Chrome Developer console.

There’s definitely something going on here that looks like it’s trying to log you out, then redirect you back to www.rhino3d.com.

@will can you see anything in this redirect loop?

Ah, OK, developer console. OK, that does seem to have worked for now, thanks!

You’re welcome. I hope this doesn’t come up again. If it does, I’ll try to be a bit more diligent about figuring out the cause instead of the workaround.

My best guess is that the browser session got into a limbo state with respect to the login status. If it happens again, we can try recording all of the requests from the Network tab of Chrome’s dev tools to see what’s going wrong. I’d also try going to https://accounts.rhino3d.com and logging out (login first if not already) and then go back to https://www.rhino3d.com to see if the problem is resolved.