Empty file

I file I have been working on for months (about 100 MB) was completely empty today when I opened it! This is of course very bad, but there’s more…
I opened my backup (V5) file and tried to close the empty (V6) file -> crash! I did send in the crash report.
I’ll send the files directly to McNeel later today.

This is the second time in a few months this is happening. Very scary!
I can’t remember if it’s the same file as last time or not.


Obviously, that’s bad.
Can you describe the circumstances surrounding the last time you worked on the file and saved it?

I’m not quite sure if it’s Rhino’s fault - or Apple’s - or my… I usually model in V6 (on my desktop) and export the file as V5 before I close the session. I then make a backup of both files (V5 and V6) sending them to my laptop using “AirDrop” (I also have additional, automatic backup on my “Time Capsule”).
I think the problem might have to do with sending the file with “AirDrop” to my laptop while the file (V6) is still open on my desktop… but I’m not sure, just guessing.

MacBook Pro.txt (2.5 KB)
iMac Pro.txt (2.6 KB)


If the file is being updated and saved at the same time it is being sent, who knows what could happen.

Other than to try to identify a pattern for when it is likely to fail, I don’t know what to suggest.

I need to test this some more - later, when I’m not so busy…