Element Style 2D block not showing


I’m having trouble getting the 2d block to display with a specific element style (attached). It is cleaned up manufacturer 3d and 2d model. The 3d model shows in perspective and I can get a 2d projection if I untick the 2d block, but the 2d projection is not looking good. If I tick the 2d model in the element style nothing shows up. I can’t figure out what that problem is.

Wave45.val (413.9 KB)


Hi Filipe,
You need to assign a different block for the Model and the Plan view representation of that Element style. You have assigned the same block for both representations. The “Plan” representation block must be created with only 2D flattened geometry.

Hi Francesc,

I know that, but you are right, I sent the wrong file version.
Wave45.val (417.7 KB)

Hi Filipe, the problem is that the Base point used for the 2D block is far away from its geometry. You need to edit the 2D block and set the Base point next to it, in the same “projected” position as the 3D block used for that Element style.

You mean the ModelBasePoint? Because the 2d geometry is not a 2d block.

I mean the base point of the block used for the plan representation of that element style.

Like I said, the “2d block” is just a 3dm file with 2d geometry, no block inside. So I can’t possibly set the 2d block basepoint. Yet, in that model the file ModelBasePoint was set to some crazy coordinates. Setting the ModelBasePoint to 0,0,0 indeed solves the problem and the style now shows the 2d plan correctly.

I imagine that VA is taking this model property when there is no 2d block inside the file. I didn’t understand that having the geometry grouped in a block was a requirement. In any case problem solved. Thanks!

As soon as you import a style that is using blocks, they are embedded in the 3dm file. So after importing your .val, I could insert the block used for the plan representation of your style.

Then I edited the block, and figured out the base point was far away from the geometry:

If you are going to use a 3dm file as the Model or Plan representation of your object style, make sure the geometry sits properly on the 0,0,0 coordinates of that 3dm file, which will become the base point of the block.

Thank you for the detailed rundown. This simplifies handling misaligned files

This is not correct. It is not enough to place the drawing at 0,0,0 coordinates in the 3dm file. Attached is an example that is at 0,0,0 with the modelbasepoint defined to something other than 0,0,0. When you insert the file the modelbasepoint is taken as the block basepoint. We actually use this modelbasepoint a lot to place topography plans at 0,0,0 coordinates in the VA model, so I should have figured this out.

Sanitana_WAVE45_wrongpoint_2D.3dm (50.7 KB)

You are right. If the modelbasepoint in the 3dm file has been changed, so it is different than the 0,0,0 coordinates, (which I assumed it was), it will be taken as the block base point.