Edition not showing causing error in License check

Hi everyone,

we have set up a license key system…

If we add the license key to the account of my colleague it shows this and we are able to add it:

If I add it to my account (German, if this makes a difference) It does not show the “Edition”

If my colleage reuests a license, it is nicely checkd out and works.

If I try it, I see that the license is blocked in the account

(The real time usage turns read)

But I get this pop up:

(Roughly saying “Object reference wasn’t set to an Object instance”)

I hit cancel - this pops up.

I click on “login as”…
This pops up again.

If I hit cancel the programm procedes without a license. (is not loaded)

Any Idea if this “Beta” not showing up is related to the error and how we can resolve this?


After clicking the Cancel Button on second pop-up
the lic file is created at %ProgramData%\McNeel\Rhinoceros\6.0\License Manager\Licenses

Hi Martin, can you confirm that you don’t see the error when Rhino’s language is set to English? What about another language (not German)?

Your issuer server is setting the license “edition” to null for German when the license is added to Cloud Zoo. I think this might be the cause of the problem, but we’ll need to double check.

"editions": {
	"en": "Beta",
	"de": null

Hi Will,
thank you. I couldn’t change the language setting unfortunately because if I try the browser country detection is setting the page back to German.

(But I guess that’s an unrelated topic).

So, if we want this to work in every language, we’ll just keep the english entry and then all languages
(German, French, Chinese, etc.) will be having the word “en” displayed. Correct?

We’ll change this and delete the German Entry completely.

The "de": null is definitely the cause of the licenses portal (Rhino Accounts) showing an empty edition when the browser language is set to German. If the “de” key was not present then the UI would fall back to the English string.

Rhino uses the same logic, however I’m still not entirely sure what’s triggering the null reference exception here. I’ve tried reproducing the same situation that you have using my own test plug-in, but I never saw the error.

Please let me know if removing the “de” key (i.e. "editions": { "en": "Beta" }) solves the issue. You might need to logout of Rhino to test properly (_Logout).