Editing objects within a group

Can someone please enlighten me how I can edit an object within a group. This is after I have pressed shift control to select the object. Now, I would like to actual select surfaces, edges, etc within the object, but shift control only lets me select the object.

Any help would be appreciated.

Maybe by running “Isolate” / unisolate once the objetc is selected.

Hi - for direct manipulation of subobject edges or surfaces, you can turn on the Sub-objects option in the Selection Filters toolbar and then window-select a surface or an edge. You might have to turn off Points/Vertices and/or Curves/Edges, etc. to be able to select what you need.
(FWIW, this has been tuned and I find that it’s easier in the Rhino 7 WIP to sub-object select elements of objects that are grouped without having to deal with filters)

As a quick alternative, use the Isolate feature as @piem proposed or use RemoveFromGroup and AddToGroup.

Isolating it does not make any difference. Neither does the sub object filter settings.

Hi - in that case, we’ll need a file and detailed instructions.

Perhaps move the group to it’s own layer, then ungroup? By putting it on it’s own layer you can easily re-group when you are done editing. Or have I misunderstood your question?

Hello - ctrl-shift select should offer edges etc on a grouped object if you click on them - do you not get that behavior?


No, ctrl-shift selects an object within the group, but that’s it. Only selects the object, not any of the sub-objects - surfaces, edges or control points.

In the first image we have the group.

In the 2nd image shft-ctrl click on the extruded polysurface to select it.

In the 3rd image it is isolated. shft-ctrl click a thousand time, but still no sub-object selection. Tried this with ‘sub-objects’ on and off in the selection filter, with no effect at all.

We have just tested it in Rhino 5 and it works, but Rhino 6 definately not.

Hi - you should be able to sub-object select edges and polysurface vertices but not faces with CtrlShift in Rhino 6.
When you turn on Sub-objects in the filters, you should be able to window-select a face (without using CtrlShift).

The following screen recording is from Rhino 6.

If this above is not possible on your system, please export your settings to a *.ini file and I can check if there’s something going on there.
Note, as I wrote above, this works better in Rhino 7.