Edit Materials Transparency not working WIP 5C41W

Working on a file in Rhino 5.1 yesterday …

and I opened it in WIP this morning and my “Picture Frame” image was sort of not there, but still there. Set transparency to 60% for this screenshot.

Playing with the transparency option in Edit Materials and the images has only on & off at around 59%, here is transparency set at 58% …

«Randy

Thanks, I see this too. Filed as http://mcneel.myjetbrains.com/youtrack/issue/MR-2401

Hi BrianJ, Some update on this problem? With WIP 5C133w the problem remains. Very difficult to work with non-transparent background images (maximum value usable 59%)

I’m not sure what’s going on here. In the latest WIP 5C133w, transparency of pictureframe materials appears to be working correctly. In the release build, I can get it to work if “use GPU lighting” is on in the active display mode. The bug report is still open though which makes me wonder if it might be fixed by way of another change in the WIP. Make sure you’re using the default display mode settings for non-rendered modes and check the rendered mode too which should have the GPU lighting option enabled. If you still can’t adjust the transparency value, please post some screenshots and the info on your GPU please.

@dan do you have any other info on this one? It’s set to be worked on for 5.3 but it appears to work correctly in the WIP now. In wireframe without GPU lighting for instance seems to work fine for transparency.

It works fine here in WIP 5c133w & 5.1 on El Capitan. I seemed to have had an issue a few weeks ago. I haven’t been in Rhino much for the last month, setting up an IT dept. It seems to have been at home on Yosemite, if I remember. I will try to check tonight.

FWIW «Randy

I think this is a good guess…though I can’t seem to find a resolved issue whose “fixing” might have impacted this.

I cannot reproduce this in 5C133w. The difference between viewport (Rendered) and a rendering is obvious, but that doesn’t seem to be what the bug is reporting.

I don’t have any additional info on this one. I definitely have GPU enabled lighting on in the rendered mode.

Update. I set the active GPU lighting and I get abnormal behavior. In files running the problem remains (adjustable maximum transparency 59%), but if I copy the background image and paste it into a new file can reduce correctly transparency. I’ll try to do more testing.

So, just to add some weirdness to this. I had imported 6 drawings on different sub-layers under a Drawings layer.
i then made all my sub-layers for the 2D lines under a lines layer. I ""turned on one of the Drawings sub-layer and the corresponding Lines sub-layer to start drawing from the “picture-frame”. All of a sudden I don’t see the locked image on the Drawings sub-layer. I decide to turn-on some other drawing sub-layers, nothing.
I open my Materials Editor once I unlock one of the sublayers and realize that the drawing is still there. Here is what I see.

Software information

Software versions
Rhinoceros version: 5.2 WIP (5C133w)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.11.3 (Build 15D21)

Plug-ins
/Users/jp-rhino3/Library/ColorPickers/SkalaColor.colorPicker/Contents/MacOS/SkalaColor

Third party kernel extensions
at.obdev.nke.LittleSnitch (4360) 2CFD591A-C820-3524-B989-3D2A63A2F8EF

Hardware information

Computer hardware
Hardware model: iMac12,2
Processor: Intel Core i5-2500S CPU @ 2.70GHz
Memory: 20 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon HD 6770M 512 MB
Memory: 512 MB
Screen size: 2560 x 1440, 1440 x 900
Displays: iMac (109dpi 1x), SyncMaster (89dpi 1x)

USB devices
Apple Computer, Inc.: IR Receiver
Apple: Card Reader
Apple Inc.: FaceTime HD Camera (Built-in)
Microsoft: Microsoft 3-Button Mouse with IntelliEye™
Apple, Inc: Apple Keyboard
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.40.16
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

So far so good with “Official” Rhino 5.1

Fingers crossed

The problem of background images that disappear if you reduce transparency over 59% continues.

Software information

Software versions
Rhinoceros version: 5.2 WIP (5C146w)
IronPython version: 5.1.2015.131
Language: it (MacOS default)
OS X version: Versione 10.11.4 (Build 15E65)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Third party kernel extensions
com.3dconnexion.driver (10.2.5) 403007CA-7295-332E-9F17-DC3EA5DFD88D

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470 CPU @ 3.20GHz
Memory: 32 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 680MX 2048 MB
Memory: 2048 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Bluetooth USB Host Controller
Inateck USB to SATA3 Bridge: Inateck Generic USB Device
Lexar: WorkflowD512
3Dconnexion: SpaceMouse Pro
Wacom Co.,Ltd.: CTH-460

Bluetooth devices
Apple: Apple Wireless Keyboard
Apple: Apple Wireless Trackpad

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.10.5.2 310.42.25f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bit
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: Yes

Appearance settings
Antialiasing: 4x
Mip map filtering: Nessuno
Anisotropic filtering: Nessuno