Edit button is unresponsive

#1

When I open iRhino I can click on the edit button to delete files from the models page. Once I open a file and then go back to the models page, the edit button is not responsive. Sometimes clicking the edit button results in a crash, but mostly it just remains unresponsive. Can you confirm this?

0 Likes

(Dan Belcher) #2

I can’t reproduce this in iRhino 3D 2.1.5. Here is what I tried:

  1. Open iRhino 3D.
  2. Tap Edit. Models dance and I deleted the sample Teapots model.
  3. Opened the Rhino Logo model by tapping on it.
  4. Tapped the Models button to return to the main Models Browser screen.
  5. Tapped Edit.

It worked as expected. (I’m probably not recreating the desired behavior to make the bug happen).

What steps should I take to reproduce this? (Also, are you on iPhone or iPad?)

0 Likes

#3

OK… I have tested this out in various situations to where I can reproduce this every time. This only happens when the iPad operated laying flat on its back ( I know… it sounds strange). If I pick up the iPad it works as it should. I have included a video to show you what I am experiencing so you don’t think I am crazy.

https://dl.dropboxusercontent.com/u/15604441/iRhino3d%20Edit%20Bug.MOV

1 Like

(Dan Belcher) #4

Nice! Thanks for the detective work. I’m sure I can reproduce this now and I can already guess what is causing it…

iPad operated laying flat on its back ( I know… it sounds strange)

Not strange at all…this is the critical hint. iPhones and iPads can return a lot of information about their orientation to the developer at any given time, and we have to react to that information. For example, here at the states that iOS can returns for the device orientation at any given time…

UIDeviceOrientation.FaceUp
UIDeviceOrientation.FaceDown
UIDeviceOrientation.LandscapeLeft
UIDeviceOrientation.LandscapeRight
UIDeviceOrientation.Portrait
UIDeviceOrientation.PortraitUpsideDown

and…drumroll please:

UIDeviceOrientation.Unknown

As developers, we are constantly having to react to the different states and “do stuff” with the interface. I think I’m not reacting to UIDeviceOrientation.Unknown the right way on that top toolbar and the button’s target hit area is somewhere else on the screen.

I can fix this (IR-477)…especially when you’ve done 90% of the sleuthing.

Thanks again!

0 Likes