Edges dropping in and out


I’ve had this problem for a couple of months now.
Basically, my display modes which have Surface Edges toggled ‘On’, the edge flickers in and out as a zoom and rotate around my model. I want my edges ON. I’m using shaded mode mostly, but this also happens in Arctic and Rendered too.

Video Attached (apologies for the quality), Display Mode settings attached, and SystemInfo below:

Rhino 7 SR19 2022-6-14 (Rhino 7, 7.19.22165.13002, Git hash:master @ 303aecd3f1907d87fe49f88f695c02fb790b1e31)
License type: Commercial, build 2022-06-14
License details: Cloud Zoo

Apple macOS Version 12.6 (Build 21G115) (Physical RAM: 16Gb)
Mac Model Identifier: iMac18,3
Language: en-AU (MacOS default)

AMD Radeon Pro 575 OpenGL Engine (OpenGL ver:4.1 ATI-4.8.101)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: Radeon Pro 575
Displays: iMac (217dpi 2x), Unknown (144dpi 2x)

Graphics processors
Radeon Pro 575 (4 GB)
iMac (2560 x 1440)
Sidecar Display (1288 x 946 @ 60.00Hz)

USB devices
Apple Inc.: iPad
Broadcom Corp.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Logitech: USB Receiver
Western Digital: My Passport 0748

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino 7 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.19.22165.13002
/Applications/Rhino 7 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 7.19.22165.13002
/Applications/Rhino 7 2.app/Contents/PlugIns/NamedPositions.rhp “Named Position” 7.19.22165.1002
/Applications/Rhino 7 2.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.19.22165.1002
/Applications/Rhino 7 2.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 7.19.22165.1002
/Applications/Rhino 7 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.19.22165.13002
/Applications/Rhino 7 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.19.22165.13002
/Applications/Rhino 7 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.19.22165.13002
/Applications/Rhino 7 2.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.19.22165.1002
/Applications/Rhino 7 2.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.19.22165.1002
/Applications/Rhino 7 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.19.22165.13002
/Applications/Rhino 7 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.19.22165.13002
/Applications/Rhino 7 2.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.19.22165.1002
/Applications/Rhino 7 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 7.19.22165.13002
/Applications/Rhino 7 2.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.19.22165.1002

I am not sure about MAC
your 575 pro card is released in 2017 and it support opengl 4.6
but according to your systeminfo, opengl version is only 4.1 (released in 2010)
I think something might be wrong with your graphic card driver.

I am up to date with my Mac OS updates.So, I’m running the most recent OS which would be updating the graphics drivers. What do you mean by ‘something wrong’?

your 575 pro card is released in 2017 and it support opengl 4.6
but according to your systeminfo, opengl version is only 4.1 (released in 2010)

I think I found the reason behind opengl 4.1

the 1st answer is pretty clear.

Since rhino’s min requirement is opengl 4.1 I think your imac will work fine.
There is no way that some random line display depends on opengl 4.6 not 4.1
The prolem may caused by other things instead of your video driver.

Please check your model size/unit and check the xyz coordinates of the wall corner.
is xyz too big?

That is a bit misleading in our SystemInfo command. Mac OpenGL only goes up to 4.1. If you have OpenGL tessellation turned on in the OpenGL settings for Rhino, try turning it off. This may help with the flickering.

1 Like

Hi! That fixed it! What does having Tessellation turned on do anyway? Will I find differences in the running of my program with it now checked off?

I got the link here.

GPU tessellation is a technique for drawing wires in OpenGL that makes display quite a bit faster. Unfortunately this feature never really worked very well on Mac and I probably should have made it a Windows only feature.

1 Like