.e57 import coulor/intensity support


#1

Hi,

I need to import a colour point cloud from laser scan data into Rhino, an I am trying to figure out with the supplier which format he should provide me.

I just tried to import .e57 files from this page which was suggested in another post:

http://www.libe57.org/data.html

but any file I open I get an error, even the simple B&W Bunny.

Just noting that my WIP expired and I can’t install an new one because of the win7 installer bug, but import functions should still work or?

but back to my question, is there any straight forward way to import architectural laser scan data including surface intensity and RBG data into Rhino 5/6?
would be glad for a hint

thanks,
daniel


(Bob McNeel) #2

@tim Can you help?


(Tim Hemmelman) #3

Hi Daniel,

I tried 4 different files from that site (bunnyDouble.e57, pumpACartesian.e57, pump.e57, Trimble_StSulpice-Cloud-50mm.e57) and they all came in fine (including color) in the current in-house WIP. I’ll ask about the Windows 7 installer bug, I am not familiar with that issue. I think the next public WIP, assuming it will install on Windows 7, should work for you. If it doesn’t post here again.

Tim


(Dale Fugier) #4

Hi Daniel,

I am (also) not having any issues opening any of the standard E57 samples (see attached).

You mentioned you were getting errors. Can you share what those errors are?

Also, both version of the importer (the one for Rhino 5 that is on Food4Rhino and the one included with the WIP) will import RGB colors from E57 files. The Rhino WIP version will also import intensities, but the WIP does not yet have a way to display them.

– Dale

bunnyDouble.zip (1.0 MB)


#5

Hi Tim,
Hi Dale,

thank you both for replying so fast!

I am not sure what is wrong with my WIP, probably some import module is not loaded when it is expired? i got a simple line printed in the command like “error loading file C:…”

I then downloaded the labs 5.0 plugIn and managed to import the .e57 fine, also the examples including colour information. So I will stick to .e57 with the scan job.

thanks again,

Daniel

btw. the installer bug is mentioned here, I think you are aware of it already and it should be fixed by now: