#$#@! DXF file association


#1

Just been trying to associate dxf files with Rhino on my colleague’s computer - for about an hour - no dice. Rhino doesn’t even show up in the “Open with” list, and when I try to point it there, it won’t even let me click OK to validate. No matter from which end I try to work it (Windows file association etc.), I always end up going around in circles.

Also tried editing the registry under HKEY_LOCAL_MACHINE\SOFTWARE\Classes.dxf\OpenWithList but no help there either… Seemed like this was a problem a long time ago - why hasn’t it been fixed?

–Mitch


(Wim Dekeyser) #2

Hey Mitch,
No such problem here. First I picked the first Rhino that appeared and that turned out to be v4 but then I went in again - RMB > Open with > Browse… (with Always use… selected).
Win 7 64-bit.


#3

Well, on my colleague’s computer, no Rhino appears at all. And no possibility of making it appear. Looks like this thread is expressing a similar problem with IGES file association. File association has been a known problem since SR0.

–Mitch


#4

Does anyone have an answer on this?: What registry entries do I have to create to force this to work?

–Mitch


#5

I have problems with assosiating stuff with V5. It insists on opening files in V4.
Even if I rightclick and choose V5 64bit.


(Willem Derks) #6

Hi Mitch,

FWIW
I remember using this tool (or alike) to un-associate in order to create a clean new association.

It’s standalone, so no install hassle.

-Willem


#7

Thanks Willem, I remember having done this on my old install a long time ago… Forgot about that utility. In fact, it helped solve part of the problem, but I finally had to do some more manual work For anyone else that has to do this:

  1. Just un-associating the file type did not allow me to set Rhino 5 x64 as default.
  2. I actually had to use the other tool in the utility - REMOVE file type.
  3. I had to run that THREE times to get rid of the file type from the list
  4. At that point I STILL could not re-associate DWG or DXF with Rhino 5 x64.
  5. I then opened an admin-level Windows command prompt (in search, type cmd and “run as admin”…)
  6. Type assoc .dxf=Rhino5x64.Document and Enter
  7. Now right click on a DXF file and choose “Open with…” you should find Rhino 5 x 64 in the list, choose that and check “Always use this program…”
  8. Done (finally!)

Needless to say, this REALLY should not be necessary!
–Mitch


#8

Ha, anyone who can’t figure THAT out don’t deserve to be able to double click on ANY file type if you ask me. Noobs!

PS! Thanks for sharing!