Dup edge dashed line


#1

All of a sudden the lines that are created when I duplicate edge are dashed. Why? and how do I set it back to creating continuous lines?


#2

Hi slam, have you accidentally set your Layers Linetype to dashed in the Layer tab (dialog). ? If you right click on the word “Name” you can enable “Linetype” then check if it is set to “Continuous” or “Dashed”.

c.


#3

thanks for the reply clement. that’s not it, but since i posted the original message i’ve discovered that it was only happening when i duplicated the edges of a certain object, and that when i duplicate any edges of other objects, it’s normal. so it’s still a mystery, but at least it doesn’t get in the way of my work! now it’s just a curiosity…


(Margaret Becker) #4

Is it possible for you to post that object? We might be able to figure out what the problem is.


(Pascal Golay) #5

Sarah, can you post that object in a 3dm file or send it to tech@mcneel.com?

thanks,

-Pascal


#6

Hi all,
As I was about to post the offending object per your requests, I noticed that the object (the closed polysurface resulting in the dashed duplicated edges) itself was set to have a dashed linetype, so I guess that explains it! Thanks for all your help!


#7

Strange, i´ve tried that first and found that i cannot repeat it over here with polysurfaces and extrusions the Linetype setting is not transferred to duplicated curves. Glad the issue is resolved, though.

c.


#8

dashed object.3dm (375.1 KB)


#9

did that work? i’ve never tried posting a rhino file before…


(Pascal Golay) #10

Hi Sarah- yep, that worked, thanks- checking it now.

Hmm- can’t make it happen yet here- Duped edges have linetype assigned by layer…

-Pascal


#11

hmmm. that is strange…


(Willem Derks) #12

Hi Pascal,

Sub-selecting the edge and a "_Copy Inplace " does get a dashed line.
And a copy-drag with gumball on the edges also gets them dashed.

@slam Sarah, how did you duplicate the edge?

-Willem


#13

I can repeat Sarah`s problem if i sub-select the edge like Willem demonstrated followed by “Copy Inplace” or “Copy”. Just wondering why it is possible to apply a Linetype to non curve objects (including points) if the outcome using LinetypeDisplay is not visible at all ?

c.