Drawing disappears when closing block editor

@CharlieBrown - is this also on Mac?

-Pascal

@vonn - thanks, I’ll see if I can reproduce this with your file. So far, I have not been able to…

Was there ever anything other than block instances in this file?
When you exit the block editor, is it by clicking on Apply, or the X in the upper left?

-Pascal

@jari.huuskola @pascal I can confirm that in one case I saw that too but in most cases the whole file was completely or almost completely empty

I had the same problem with all the objects disappearing from my file on Windows(nearly experiencing break-down) after hours of editting blocks in blocks! However I found a back-up file almost similar to the latest file I was working on in my Rhinoceros/Autosaved files, I think that is the best you can do.

This is a massive issue,It’s just happened to me AGAIN!

I have saved the file without plugin data and now it is useable again,But for how long?

Happened to me again yesterday! I am living with this issue now ahaha, gluing my fingers to Ctrl+S.

It seems to happen when immediately clicking after closing the block editor. Seems to suggest the drawings get corrupted while the block is trying to save the changes and update other instances. The block manager still contains the items but nothing is shown on the viewport. It’s a major issue and countless hours have been lost. Sorry to say but we’re seriously reviewing if we can continue using this software… :frowning:

that’s it! I managed to replicate it two times in a row. Double click or click multiple times fast on the apply button and everything is gone! @pascal

Just happened again and this time I didn’t think i clicked it that soon after exiting the block. It may be that the file is getting bigger so the lag in saving to the block manager grows and the ‘opportunity’ to click too soon and losing the drawing increases. If this is right, then small files don’t face this issue as much as a heavy file…

Hi all - we have examples (thanks) that show the problem - I will check with the developer @JohnM - what is the current state of this bug? I think you made some changes but I do not quite know where we are since we looked at it last week.

-Pascal

Just happened to me aswell after closing the block editor.

Hey ! Same thing happened to me while editing a block. I exited the block editor and everything vanished. I decided to make a new file but before abandoning this one i checked my block manager and exported all the blocks as i made many myself. To my surprise when i imported these blocks to a new file, everything from my old file was actually inside the block i was editing last because if which everything vanished !
I doubt ive ever felt more lucky haha but yeah this was the case for me got everything back…so may be you guys can try this just in case.

Otherwise i also went to my last autosave that helps too :slight_smile:

Just go to the block manager and export the block you were editing the whole file might be in it.

Just happened to me.
I edited a block and after clicking ‘apply’ the whole model disappeared and annoyingly I saved in the hope it would refresh the model but it didn’t and the file was now saved as empty.
Luckily I followed what Sewenphotophile mentioned and exported the block to regain EVERYTHING except for the block I had just created.

It was a scary moment… please sort and if you need a file I can send.

happens all the time when working with blocks. how is that not fixed in more than two years?

All, just had this issue - used the ‘selblockinstance’ command and there are no blocks in the model space. Empty file except for the two objects I was editing in the block before I closed it.

While this remains unresolved I would recommend everyone setup autosave. I hadnt hit control+s today, but luckily have an autosave from 30 mins ago. Sketchy bug - hope it’s fixed soon.

@pascal @JohnM some of my students are still running into this severe bug during block editing. I’ve reported a way to repeat this issue but I cannot see that this was picked up? Mac revert file has been able to recover the work partly, but still…

Gijs, thanks for the nudge - I’ve tried to reproduce this from scratch a number of times without success but just tried again and made it happen - if I can reproduce it reliably, that means it can almost certainly be fixed.
RH-64812 BlockEdit - objects disappear

-Pascal

1 Like