Drawing disappears when closing block editor

Sorry I’m replying to myself. I solved my own question! My ENTIRE drawing somehow accidentally ended up in one of my “Blocks” that I made…

Thats so odd! I had about 4 blocks and someone a bunch of layers all copied themselves onto one of my blocks… I don’t suppose anyone else had this problem? Or perhaps it was just me…

This just happened to me too… and just like you said the entire drawing can be found inside of one random block in my project too! Very strange and odd indeed.

I hope this get fixed soon. This wasn’t my first time with this bug, but at least now I know what to look for when this happens next time.

Once again entire drawing inside one random block… nice.

Can you please send a file and the instructions needed to repeat this problem?
If we can repeat it, we can git it on the pile to be fixed.


This just happened to me (Rhino 6.30 on Mac). I really don’t know what triggered it.
I open BlockEdit, did my modification and when I clicked Apply everything vanished.

As some user here pointed out, I looked into every single block that was in the file (A LOT & TIME CONSUMING) and finally found it in the block that I was editing (of course that block was near the end of the list, but next time it happens I’m sure going to check that edited one first…

I really hope this gets fixed… It’s annoying if it keeps happening and not good for the stress either.


Thanks for the report. I’m trying to reproduce this but so far can’t using the same build. Do you have a 3dm file with a block in it and the steps to reproduce this? One thought that may be a variable is where the 3dm is saved on your Mac. Is it in a cloud synced folder for instance or on an external drive? I’m wondering if macOS versioning might be involved but this is just a guess at the moment. We’ll need to reproduce it here to get it in front of the developers.

I was using files in a cloud folder and by stopping the sync I was able to retrieve an older version of the destroyed file (at the moment I also had rhino autosave on). It was a linework file and the objects are definitely not hidden, as the file size reduced from 33MB to 4MB. Personally, I have also noticed other irregularities when I am constantly working on a file that contains blocks, i.e. assigned linetypes changed, all 2d objects swapped layers or the layer colours shuffled, which is very very weird. Anyways, here is my file after data loss. AFTER.3dm (4.5 MB)

This just happened to my twice with Rhino 7 (7.2.21012.17002, 2021-01-12) on Mac. My File size reduced from 84MB to 4MB. Could restore an older file with “Revert to”, nevertheless hours of work vanished. I don’t know how to live with this Problem. Not using blocks and groups anymore?

Have been encountering this issue on (6.34.21034.07002, 2021-02-03) multiple times similar to the previous posters about editing blocks… I use time machine backup with the file open and roll it back one step (assuming you are trying to recover your latest work immediately after the issue arises). The other issue is as what some of the previous posters mentioned, eg. objects moving to different layers, block text being either duplicated (outside of the block) or not updated. This more frequently happens when I edit the type in the Properties: Text sidebar but not when I double click the text for the pop up to appear.

Hi All!

I am so glad I found this thread because I am having the same issue. I just deleted my previous message about it on accident, lol.

Anyway, it happens to me in both V6 and V7 for Mac, both are updated to the latest builds and my computer is running MacOS Catalina 10.15.7 (19H524)

It seems to happen if I click one too many times right after exiting the block editor - all of a sudden everything disappears. It’s not hidden or deleted, and I cannot undo the action to get it back, like others who have posted, I have to revert to a previous version to fix it.

Please let me know what I can do to help with this - I copied the model that appears to be “blank” and could share that with the McNeel team to take a look… The file is still 17MB even though it looks like there is nothing inside.

I can send more info on my computer etc as well if that’s helpful. Let me know.

I want to make another report of this. One of my students actually had it happen right in front of me when changing content in a title block in layout mode. After ‘Apply’ the complete content of the file was gone. Could it have to do with Mac operating system doing an automated save on exactly the wrong moment, so it saves in block edit stage where no other geometry is visible?
Then I had another emergency case this morning to solve: Another student had a almost completely empty file as well. The only rescue was to browse to a multiple hours earlier version of the work. This is a huge bug that needs to be solved asap. Also this is what her layers looked like when it happened:

as you can see all the layer colors and print width info is gone.

I agree. This is scary…


I’m so glad more people are finding this and flagging it - not sure how we get a response from @mcneel on here though. I still have my “empty” file I can share if that is helpful.

@JohnM - fyi, this thread - I will try to reproduce it…

I was able to reproduce a crash twice, testing for this but not the disappearing contents, so far.
RH-63384 BlockEdit: Crash on exit


@vonn - can you pin this down any more ? You click apply on the block editor, and until you click (someplace) again, the file looks correct? Is this in a layout or model space, or both?


@pascal I think what was not 100% clear from my post: both cases I reported happened when doing a block edit in layout mode. I also have the (almost) empty file of the student if that helps.

Hi Gijs - thanks - yes, please send us that file - here, via PM or via tech@mcneel.com.


I can never seem to reproduce the issue but it seems to happen after I click apply in the block editor and then click again as it’s exiting the block editor - suddenly, everything is gone except for the one block. When I click back into the block, nothing is in there either. I attached the file where this happened and it now appears to be empty despite still being 17MB of ‘something’ … I had to revert back to an older version (and lost a lot of work) in order to keep working with this file. I’m sorry that still isn’t that specific. I can say that it has nothing to do with layout mode as Gijs mentioned - I don’t even use layouts in Rhino.

1_BUILDING.3dm (16.7 MB)

Adding to the pile here too.

Changed the material of a component in the block and then everything dissappeared.
Tried “looking in the blocks” as other users suggested, but not even sure what that means - the blocks are what I drew them to be by the looks of it in BlockManager. Phantom 17MB of stuff left.

Take a closer look at your blocks. One block will contain your root level drawing. Thats what “looking in the blocks” means.

1 Like