Drape Points (Drapept) stopped working

I used to use the Drape points (drapept) command over portions of pointcloud scans. It worked beautifully for what I needed it for. Just recently it has just failed to drape any points. the command executes, but there are no points after the command finishes.

I have not changed anything(that I am aware of), and this command was extremely helpful. Please help!
Thank you

Hi -
This seems to work here but I’m not convinced that it should work on pointclouds.
Could you post a file you are having issues with and also run the Rhino SystemInfo command and copy-paste the result here?

The file is very large as it contains a point cloud.(4gb) hard to post that…any other suggestions?

Rhino 6 SR31 2020-11-10 (Rhino 6, 6.31.20315.17001, Git hash:master @ ff08c426b1ef7d3a1c50a01e5e87220a68a9f815)
License type: Commercial, build 2020-11-10
License details: Cloud Zoo. In use by: Steve K ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: DESKTOP-856OBS4

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P4000 (NVidia) Memory: 8GB, Driver date: 7-13-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 451.77

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-13-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Hi Steve -

I’m afraid it wouldn’t do any good sending that file over to me. I don’t have the hardware that is able to deal with a file like that.
You could test with a much smaller file.

cloud sample.e57 (4.7 MB)

Let me know if this works for you

Thank you for your help.

Hello - I would not expect DrapePt to work on a point cloud - it does work on meshes.


Thank you for responding. It was working on point clouds and I was using drapept to create a mesh from a small section of a point cloud. then it just stopped … I have no explanation
Any suggestion on how to achieve this with a different method?

Hello - DrapePt creates points, not a mesh - Drape works on points but does not create a mesh, it makes a surface - that is the closest I can find to your description, is that it?
And, indeed, it seems Drape does nothing on points in V7… I should say it does nothing if no other object types are included… And DrapePt does give a result if some other object type is included … weird and messy, thanks for the report.

RH-61849 Drape and point clouds


I found drape did not work on point clouds, so workflow was as follows:
drapept --> hide point cloud --> use points from drapept command and use patch or meshpatch
to achieve a surface I could use for modeling from my point cloud. Does this help clarify how I was using it?

Thank you. This solved my problem…Thank you so much. As long as I have a solid to drape over, drape pt will drop points on the pointcloud.